aboutsummaryrefslogtreecommitdiff
path: root/emulators/stonx
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1997-10-31 09:15:15 +0000
committerThomas Gellekum <tg@FreeBSD.org>1997-10-31 09:15:15 +0000
commit86e3852b2fa504b76476502b87f6de835141bfac (patch)
treec475c7bb43bc3401f80adc299a5febac68d725b9 /emulators/stonx
parent437b3e92ccb41943793e9894d605c883f18fdaca (diff)
downloadports-86e3852b2fa504b76476502b87f6de835141bfac.tar.gz
ports-86e3852b2fa504b76476502b87f6de835141bfac.zip
Notes
Diffstat (limited to 'emulators/stonx')
-rw-r--r--emulators/stonx/Makefile75
-rw-r--r--emulators/stonx/distinfo2
-rw-r--r--emulators/stonx/pkg-comment1
-rw-r--r--emulators/stonx/pkg-descr41
-rw-r--r--emulators/stonx/pkg-plist20
5 files changed, 139 insertions, 0 deletions
diff --git a/emulators/stonx/Makefile b/emulators/stonx/Makefile
new file mode 100644
index 000000000000..f799cd6cd319
--- /dev/null
+++ b/emulators/stonx/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: STonX
+# Version required: 0.6.7
+# Date created: 3rd August, 1997
+# Whom: Tobias Reifenberger <tr@freebsd.mayn.de>
+#
+# $Id$
+#
+
+DISTNAME= STonX-0.6.7-epsilon
+PKGNAME= stonx-0.6.7e
+CATEGORIES= emulators
+MASTER_SITES= ftp://ftp.complang.tuwien.ac.at/pub/nino/stonx-current/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} tos.img
+
+MAINTAINER= tr@freebsd.mayn.de
+
+RESTRICTED= "tos.img is Copyrighted"
+NO_PACKAGE= ${RESTRICTED}
+
+IGNOREFILES= tos.img
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+HAS_CONFIGURE= yes
+
+# Source building
+#
+pre-build:
+ ${CP} ${DISTDIR}/tos.img ${WRKSRC}
+
+post-build:
+ (cd ${WRKSRC}; make fnttobdf fonts)
+
+# Installing
+#
+BINDIR= ${PREFIX}/bin
+LIBDIR= ${PREFIX}/lib/STonX
+FNTDIR= ${X11BASE}/lib/X11/fonts/misc
+
+DATA= tos.img cartridge.img Keysyms Keysyms.G atari/FLOPPY-4MB \
+ atari/bench1.pas atari/bench1.prg atari/final.tos
+DOCS= ../COPYING DEBUGGING FONTS INSTALL PROGRAMS README RELEASE_NOTES \
+ TOS-VERSIONS
+FONTS= System0-iso.pcf System0.pcf System1-iso.pcf System1.pcf \
+ System2-iso.pcf System2.pcf
+
+pre-install:
+ @${ECHO_MSG} "#!/bin/sh" > ${WRKSRC}/stonx.script
+ @${ECHO_MSG} "cd ${LIBDIR}" >> ${WRKSRC}/stonx.script
+ @${ECHO_MSG} "${BINDIR}/stonx.bin -noaudio \
+ -disk A:FLOPPY-4MB -fs C:." >> ${WRKSRC}/stonx.script
+
+do-install:
+ @${ECHO_MSG} "===> Installing programs"
+ ${INSTALL_SCRIPT} ${WRKSRC}/stonx.script ${BINDIR}/stonx
+ ${INSTALL_PROGRAM} ${WRKSRC}/stonx ${BINDIR}/stonx.bin
+
+ @${ECHO_MSG} "===> Installing data"
+ @${MKDIR} ${LIBDIR}
+.for f in ${DATA}
+ @${INSTALL_DATA} ${WRKSRC}/$f ${LIBDIR}
+.endfor
+
+ @${ECHO_MSG} "===> Installing fonts"
+.for f in ${FONTS}
+ @${INSTALL_DATA} ${WRKSRC}/data/$f ${FNTDIR}
+ @gzip -f ${FNTDIR}/$f
+.endfor
+ @mkfontdir ${FNTDIR}
+
+ @${ECHO_MSG} "===> Installing docs"
+ @${MKDIR} ${LIBDIR}/docs
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/docs/$f ${LIBDIR}/docs
+.endfor
+
+.include <bsd.port.mk>
diff --git a/emulators/stonx/distinfo b/emulators/stonx/distinfo
new file mode 100644
index 000000000000..d9c11f7efb97
--- /dev/null
+++ b/emulators/stonx/distinfo
@@ -0,0 +1,2 @@
+MD5 (STonX-0.6.7-epsilon.tar.gz) = c8a5a3bbf6a7c13c1c1e6176c6e6d93a
+MD5 (tos.img) = IGNORE
diff --git a/emulators/stonx/pkg-comment b/emulators/stonx/pkg-comment
new file mode 100644
index 000000000000..c065f3f05ef1
--- /dev/null
+++ b/emulators/stonx/pkg-comment
@@ -0,0 +1 @@
+AtariST emulator
diff --git a/emulators/stonx/pkg-descr b/emulators/stonx/pkg-descr
new file mode 100644
index 000000000000..a0c6d7ae65ee
--- /dev/null
+++ b/emulators/stonx/pkg-descr
@@ -0,0 +1,41 @@
+Release notes for version 0.6.7-epsilon
+=======================================
+
+This version is the "almost-there" version of STonX 0.6.7 (which is going
+to be the last "release" version before the major changes in the current
+development versions are released.
+
+The Xlib-VDI driver is still disabled (sorry) and may or may not be
+re-integrated before the final 0.6.7 release. This depends mostly on
+how much work it is to get it to work again after all the latest changes.
+
+Please notify me of any bugs or installation problems as soon as possible
+(mail me at nino@complang.tuwien.ac.at), even if you have reported a bug
+previously and I haven't had time or forgot to fix it.
+
+-nino
+
+Some information about the problems with different TOS versions and STonX:
+==========================================================================
+
+(1) Can't run programs from the Unix filesystem interface
+(2) not thoroughly tested or tested by someone else
+(3) untested
+(4) set TOS_1 to 1 in options.h before compiling
+(5) A: and B: can't be used because they're implicitly considered Floppy disk
+ drives and always accessed using the FDC
+
+TOS 1.00: (1)(2)(4)(5)
+TOS 1.02: (1)(2)(4)(5)
+TOS 1.04: (2)(4)
+TOS 1.06: (3)
+TOS 1.62: (3)
+TOS 2.05: tested, should be OK
+TOS 2.06: tested, should be OK
+
+Please notify me of problems not mentioned here!
+
+
+Author of STonX:
+
+ Marinos Yannikos (nino@complang.tuwien.ac.at)
diff --git a/emulators/stonx/pkg-plist b/emulators/stonx/pkg-plist
new file mode 100644
index 000000000000..0b17bef0c508
--- /dev/null
+++ b/emulators/stonx/pkg-plist
@@ -0,0 +1,20 @@
+bin/stonx
+bin/stonx.bin
+lib/STonX/FLOPPY-4MB
+lib/STonX/Keysyms
+lib/STonX/Keysyms.G
+lib/STonX/bench1.pas
+lib/STonX/bench1.prg
+lib/STonX/cartridge.img
+lib/STonX/final.tos
+lib/STonX/tos.img
+lib/STonX/docs/COPYING
+lib/STonX/docs/DEBUGGING
+lib/STonX/docs/FONTS
+lib/STonX/docs/INSTALL
+lib/STonX/docs/PROGRAMS
+lib/STonX/docs/README
+lib/STonX/docs/RELEASE_NOTES
+lib/STonX/docs/TOS-VERSIONS
+@dirrm lib/STonX/docs
+@dirrm lib/STonX