aboutsummaryrefslogtreecommitdiff
path: root/emulators/stonx
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-09-09 04:12:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-09-09 04:12:55 +0000
commita9bcb9ec32dcca62d080f04fd6ff7a05b9cda9d8 (patch)
tree1286d65edcdfe31695577f6498bce2000b996cc0 /emulators/stonx
parentdcc59c1989a1d9bfb19c52e162ce5a2ecf975b42 (diff)
downloadports-a9bcb9ec32dcca62d080f04fd6ff7a05b9cda9d8.tar.gz
ports-a9bcb9ec32dcca62d080f04fd6ff7a05b9cda9d8.zip
Notes
Diffstat (limited to 'emulators/stonx')
-rw-r--r--emulators/stonx/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/emulators/stonx/Makefile b/emulators/stonx/Makefile
index 50b668e35913..0b3221dcefd0 100644
--- a/emulators/stonx/Makefile
+++ b/emulators/stonx/Makefile
@@ -16,17 +16,12 @@ COMMENT= AtariST emulator
RESTRICTED= "tos.img is copyrighted"
-TOSIMG= tos.img
+TOSIMG?= tos.img
USE_X_PREFIX= yes
HAS_CONFIGURE= yes
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
-IGNORE="Please get a ROM dump from your AtariST and save it as"\
-"\"${TOSIMG}\" in \"${DISTDIR}\" manually, and then make install again"
-.endif
-
pre-build:
- ${CP} ${DISTDIR}/tos.img ${WRKSRC}
+ ${CP} ${DISTDIR}/${TOSIMG} ${WRKSRC}/tos.img
post-build:
(cd ${WRKSRC}; make fnttobdf fonts)
@@ -79,4 +74,11 @@ do-install:
post-install:
${X11BASE}/bin/mkfontdir ${FNTDIR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${TOSIMG})
+IGNORE="Please get a ROM dump from your AtariST and save it as"\
+"\"${TOSIMG}\" in \"${DISTDIR}\" manually, and then make install again"
+.endif
+
+.include <bsd.port.post.mk>