aboutsummaryrefslogtreecommitdiff
path: root/emulators/tilem/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-06-09 16:54:05 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-06-09 16:54:05 +0000
commit809a2e7cf17d53d29c7ad70ca07d3f8757136ebc (patch)
treead694b9a180e56cc39550110112c49e9d1986abc /emulators/tilem/Makefile
parent25a8c7e707caed44bf1f9acf411574b05cb758d1 (diff)
Notes
Diffstat (limited to 'emulators/tilem/Makefile')
-rw-r--r--emulators/tilem/Makefile43
1 files changed, 10 insertions, 33 deletions
diff --git a/emulators/tilem/Makefile b/emulators/tilem/Makefile
index 619b7e9ac305..fe78ee619c4a 100644
--- a/emulators/tilem/Makefile
+++ b/emulators/tilem/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: TilEm
+# New ports collection makefile for: TilEm (TI Linux Emulator)
# Date created: 5 Sep 2006
# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
#
@@ -6,43 +6,20 @@
#
PORTNAME= tilem
-PORTVERSION= 0.973
-PORTREVISION= 7
+PORTVERSION= 2.0
CATEGORIES= emulators
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-devel/${PORTVERSION}
+MASTER_SITES= SF
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= An emulator for the Z80 series of Texas Instruments calculators
+LICENSE= GPLv3
+
+LIB_DEPENDS= ticalcs2:${PORTSDIR}/comms/libticalcs2
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USE_GMAKE= yes # parallel builds (-jX) are broken with BSD make(1)
USE_GNOME= gtk20
-OPTIONS= TICABLES "Use ticables2 library for external linking" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_TICABLES)
-LIB_DEPENDS+= ticables2.1:${PORTSDIR}/comms/libticables2
-.else
-CONFIGURE_ARGS+= --without-ticables
-.endif
-
-post-extract:
-# Set more sane permissions for main executable
- @${REINPLACE_CMD} -e 's,711,555,' \
- ${WRKSRC}/src/tilem/Makefile.in
-# Honor CFLAGS
- @${REINPLACE_CMD} -e 's,CPPFLAGS) -O.,CPPFLAGS),' \
- ${WRKSRC}/src/tilem/Makefile.in
- @${REINPLACE_CMD} -e 's,-Wall,${CFLAGS},' \
- ${WRKSRC}/src/utils/Makefile.in
-# Remove conflicting prototype
- @${REINPLACE_CMD} '5,13d' ${WRKSRC}/src/tilem/core/dep/link.h
-
-post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/neosign ${WRKSRC}/bin/tcc \
- ${PREFIX}/bin
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>