aboutsummaryrefslogtreecommitdiff
path: root/emulators/tpm-emulator/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2010-12-14 22:49:47 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2010-12-14 22:49:47 +0000
commit3fc9cc9ed381703d46ae7fc462dc2c97c8a33913 (patch)
treec328a01ce6fd4aee3037e7fea680ac0bbd4f79b8 /emulators/tpm-emulator/Makefile
parentb144080799dc149115acb1b487af07aabdb06ff6 (diff)
downloadports-3fc9cc9ed381703d46ae7fc462dc2c97c8a33913.tar.gz
ports-3fc9cc9ed381703d46ae7fc462dc2c97c8a33913.zip
Notes
Diffstat (limited to 'emulators/tpm-emulator/Makefile')
-rw-r--r--emulators/tpm-emulator/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 8786332e580d..a065d26c9b51 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tpm-emulator
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= emulators security
MASTER_SITES= BERLIOS/${PORTNAME}
DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
@@ -47,4 +48,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
post-extract:
@${MKDIR} ${WRKSRC}/build
+post-install:
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 ${PREFIX}/var/lib/tpm
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/tpm
+
+add-plist-post:
+ @${ECHO_CMD} "@cwd /" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} var/run/tpm 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/tpm" >> ${TMPPLIST}
+
.include <bsd.port.mk>