aboutsummaryrefslogtreecommitdiff
path: root/emulators/tpm-emulator
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2010-12-14 22:49:47 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2010-12-14 22:49:47 +0000
commit3fc9cc9ed381703d46ae7fc462dc2c97c8a33913 (patch)
treec328a01ce6fd4aee3037e7fea680ac0bbd4f79b8 /emulators/tpm-emulator
parentb144080799dc149115acb1b487af07aabdb06ff6 (diff)
downloadports-3fc9cc9ed381703d46ae7fc462dc2c97c8a33913.tar.gz
ports-3fc9cc9ed381703d46ae7fc462dc2c97c8a33913.zip
Notes
Diffstat (limited to 'emulators/tpm-emulator')
-rw-r--r--emulators/tpm-emulator/Makefile10
-rw-r--r--emulators/tpm-emulator/files/patch-CMakeLists.txt9
-rw-r--r--emulators/tpm-emulator/pkg-plist1
3 files changed, 18 insertions, 2 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 8786332e580d..a065d26c9b51 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tpm-emulator
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= emulators security
MASTER_SITES= BERLIOS/${PORTNAME}
DISTNAME= ${PORTNAME:S/-/_/}-${PORTVERSION}
@@ -47,4 +48,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
post-extract:
@${MKDIR} ${WRKSRC}/build
+post-install:
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 ${PREFIX}/var/lib/tpm
+ @${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 /var/run/tpm
+
+add-plist-post:
+ @${ECHO_CMD} "@cwd /" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${RMDIR} var/run/tpm 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${INSTALL} -d -o ${USERS} -g ${GROUPS} -m 0700 var/run/tpm" >> ${TMPPLIST}
+
.include <bsd.port.mk>
diff --git a/emulators/tpm-emulator/files/patch-CMakeLists.txt b/emulators/tpm-emulator/files/patch-CMakeLists.txt
index 33f4b1b0ae15..076defe218fe 100644
--- a/emulators/tpm-emulator/files/patch-CMakeLists.txt
+++ b/emulators/tpm-emulator/files/patch-CMakeLists.txt
@@ -1,6 +1,11 @@
--- CMakeLists.txt.orig 2010-07-06 06:21:20.000000000 +0900
-+++ CMakeLists.txt 2010-12-15 07:24:08.279834034 +0900
-@@ -36,7 +36,7 @@
++++ CMakeLists.txt 2010-12-15 07:33:54.234887143 +0900
+@@ -32,11 +32,11 @@
+ else()
+ set(TPM_LOG_FILE "/var/log/tpmd.log")
+ set(TPM_SOCKET_NAME "/var/run/tpm/tpmd_socket:0")
+-set(TPM_STORAGE_NAME "/var/lib/tpm/tpm_emulator-1_2_${${PROJECT_NAME}_VERSION_MAJOR}_${${PROJECT_NAME}_VERSION_MINOR}")
++set(TPM_STORAGE_NAME "$ENV{PREFIX}/var/lib/tpm/tpm_emulator-1_2_${${PROJECT_NAME}_VERSION_MAJOR}_${${PROJECT_NAME}_VERSION_MINOR}")
set(TPM_DEVICE_NAME "/dev/tpm")
endif()
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/config.h)
diff --git a/emulators/tpm-emulator/pkg-plist b/emulators/tpm-emulator/pkg-plist
index 15185f639fe0..1e106fbe20dc 100644
--- a/emulators/tpm-emulator/pkg-plist
+++ b/emulators/tpm-emulator/pkg-plist
@@ -4,3 +4,4 @@ lib/libtddl.a
lib/libtddl.so
lib/libtddl.so.1
lib/libtddl.so.1.2.0.7
+@dirrmtry var/lib/tpm