aboutsummaryrefslogtreecommitdiff
path: root/emulators/twin
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-09-09 06:33:22 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-09-09 06:33:22 +0000
commitab3ad05398fbc8d56dbf282da5cb0b26b20ac319 (patch)
tree8f21d6c08154f135fe6b9e69381e7a9031743456 /emulators/twin
parent867666aafb58087a1bc9c498324942585b357353 (diff)
downloadports-ab3ad05398fbc8d56dbf282da5cb0b26b20ac319.tar.gz
ports-ab3ad05398fbc8d56dbf282da5cb0b26b20ac319.zip
Notes
Diffstat (limited to 'emulators/twin')
-rw-r--r--emulators/twin/Makefile9
-rw-r--r--emulators/twin/files/patch-debugger+sig_context.h25
-rw-r--r--emulators/twin/files/patch-osdll+DrvSystem_ppc-gcc.s13
-rw-r--r--emulators/twin/files/patch-tools+rc+cmdline.c13
-rw-r--r--emulators/twin/files/patch-windows+Makefile.in13
5 files changed, 68 insertions, 5 deletions
diff --git a/emulators/twin/Makefile b/emulators/twin/Makefile
index d5106d148aa1..176a23e7c72a 100644
--- a/emulators/twin/Makefile
+++ b/emulators/twin/Makefile
@@ -20,12 +20,11 @@ ONLY_FOR_ARCHS= i386 alpha powerpc
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XLIB= yes
+USE_REINPLACE= yes
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-CONFIGURE_ARGS= --disable-debugger
-.if ${MACHINE_ARCH} != "i386"
- CONFIGURE_ARGS+= --disable-intp
+.if ${MACHINE_ARCH} == "alpha"
+CONFIGURE_ARGS+= --disable-intp
.endif
USE_GMAKE= yes
@@ -37,7 +36,7 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
-BROKEN= "Dumps core at making RscData.res.c"
+USE_GCC= 3.2
.endif
FMT?= /usr/bin/fmt
diff --git a/emulators/twin/files/patch-debugger+sig_context.h b/emulators/twin/files/patch-debugger+sig_context.h
new file mode 100644
index 000000000000..1a6da2cf3044
--- /dev/null
+++ b/emulators/twin/files/patch-debugger+sig_context.h
@@ -0,0 +1,25 @@
+$NetBSD: patch-ae,v 1.1.1.1 2001/05/15 09:46:37 agc Exp $
+
+--- debugger/sig_context.h.orig Sun May 13 03:01:07 2001
++++ debugger/sig_context.h Sun May 13 03:25:31 2001
+@@ -59,6 +59,20 @@
+
+ #if defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__)
+
++enum {
++ REG_GS = 0, REG_FS, REG_ES, REG_DS,
++ REG_EDI, REG_ESI, REG_EBP,
++ REG_EBX, REG_EDX, REG_ECX, REG_EAX,
++ REG_EIP, REG_CS, REG_EFL, REG_ESP,
++ REG_SS, REG_BSD_ONSTACK, REG_BSD_MASK13,
++ REG_TRAPNO, REG_ERR,
++
++ REG_AX = 100, REG_BX, REG_CX, REG_DX,
++ REG_BP, REG_IP, REG_SP,
++ REG_DI, REG_SI,
++ REG_FL
++};
++
+ #include <signal.h>
+ typedef struct sigcontext SIGCONTEXT;
+
diff --git a/emulators/twin/files/patch-osdll+DrvSystem_ppc-gcc.s b/emulators/twin/files/patch-osdll+DrvSystem_ppc-gcc.s
new file mode 100644
index 000000000000..bdd6b4aa46fd
--- /dev/null
+++ b/emulators/twin/files/patch-osdll+DrvSystem_ppc-gcc.s
@@ -0,0 +1,13 @@
+$NetBSD: patch-ai,v 1.1 2003/03/08 03:15:52 jmc Exp $
+
+--- osdll/DrvSystem_ppc-gcc.s.orig Fri Apr 5 21:29:15 2002
++++ osdll/DrvSystem_ppc-gcc.s Fri Apr 5 21:29:27 2002
+@@ -61,7 +61,7 @@
+ mr SP,r3
+ # gcc/gas breaks on this
+ # bl .TWIN_InitStackEnd{PR}
+- bl TWIN_InitStackEnd
++ bl TWIN_InitStackEnd@plt
+ nop
+ nop
+ nop
diff --git a/emulators/twin/files/patch-tools+rc+cmdline.c b/emulators/twin/files/patch-tools+rc+cmdline.c
new file mode 100644
index 000000000000..415695579400
--- /dev/null
+++ b/emulators/twin/files/patch-tools+rc+cmdline.c
@@ -0,0 +1,13 @@
+$NetBSD: patch-af,v 1.1.1.1 2001/05/15 09:46:37 agc Exp $
+
+--- tools/rc/cmdline.c.orig Wed Aug 11 01:34:18 1999
++++ tools/rc/cmdline.c Sun May 13 10:09:31 2001
+@@ -61,7 +61,7 @@
+ extern char cpp_module_name[];
+ extern char libentry_name[];
+ extern char tbl_name[];
+-static char *system_include_path[1] = { STDINC };
++static char *system_include_path[2] = { STDINC, __INCPATH__ };
+ static int n_system_include_path = sizeof(system_include_path) /
+ sizeof(*system_include_path);
+ static char **user_include_path = NULL;
diff --git a/emulators/twin/files/patch-windows+Makefile.in b/emulators/twin/files/patch-windows+Makefile.in
new file mode 100644
index 000000000000..4ece0c06613b
--- /dev/null
+++ b/emulators/twin/files/patch-windows+Makefile.in
@@ -0,0 +1,13 @@
+$NetBSD: patch-aj,v 1.1 2003/03/08 03:15:52 jmc Exp $
+
+--- windows/Makefile.in.orig Fri Apr 5 21:33:13 2002
++++ windows/Makefile.in Fri Apr 5 20:46:17 2002
+@@ -17,7 +17,7 @@
+
+ target = $(LIBTWIN)
+
+-LIBTWIN_LDFLAGS = @LIBTWIN_LDFLAGS@
++LIBTWIN_LDFLAGS = @LIBTWIN_LDFLAGS@ ${LDFLAGS}
+
+ ############################################################################
+ #