aboutsummaryrefslogtreecommitdiff
path: root/emulators/vMac
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /emulators/vMac
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
Notes
Diffstat (limited to 'emulators/vMac')
-rw-r--r--emulators/vMac/Makefile46
1 files changed, 20 insertions, 26 deletions
diff --git a/emulators/vMac/Makefile b/emulators/vMac/Makefile
index 55ce050e3045..b56b44dd21bd 100644
--- a/emulators/vMac/Makefile
+++ b/emulators/vMac/Makefile
@@ -5,41 +5,35 @@
# $FreeBSD$
#
-PORTNAME= vMac
-PORTVERSION= 0.1.9.3
-PORTREVISION= 2
-CATEGORIES= emulators
-MASTER_SITES= http://www.vmac.org/download/XWindows/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-EXTRACT_SUFX= .tgz
+PORTNAME= vMac
+PORTVERSION= 0.1.9.3
+PORTREVISION= 3
+CATEGORIES= emulators
+MASTER_SITES= http://www.vmac.org/download/XWindows/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Emulates a MacPlus machine! Runs MacOS versions up to 7.5.5
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_XLIB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_XORG= x11 ice sm xext
pre-patch:
(cd ${WRKSRC} && ${SH} ${FILESDIR}/dos2unx gemulator.c)
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/vMac \
- ${PREFIX}/bin
- @${STRIP_CMD} ${PREFIX}/bin/vMac
+ ${INSTALL_PROGRAM} ${WRKSRC}/vMac ${PREFIX}/bin
+ ${STRIP_CMD} ${PREFIX}/bin/vMac
.if !defined(NOPORTDOCS)
- @ ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/CREDITS \
- ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/INSTALL \
- ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/LICENSE \
- ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README \
- ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.rom \
- ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.rom ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE} | ${SED} -e s:/usr/local:${PREFIX}: