aboutsummaryrefslogtreecommitdiff
path: root/emulators/vba
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-21 22:43:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-21 22:43:20 +0000
commitd3ced2683a4f26ab1b2ba8f49fe06eab8720e9f3 (patch)
treeb12dad4c56f2caf7e50a2321eea986e16a0dbfcc /emulators/vba
parent12f8a5958ef3e8b9ae65da09dc2044ab06b48960 (diff)
downloadports-d3ced2683a4f26ab1b2ba8f49fe06eab8720e9f3.tar.gz
ports-d3ced2683a4f26ab1b2ba8f49fe06eab8720e9f3.zip
Notes
Diffstat (limited to 'emulators/vba')
-rw-r--r--emulators/vba/Makefile25
-rw-r--r--emulators/vba/distinfo2
-rw-r--r--emulators/vba/files/patch-aa8
-rw-r--r--emulators/vba/files/patch-ab125
-rw-r--r--emulators/vba/pkg-plist2
5 files changed, 95 insertions, 67 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index 1bb4348f04bd..676f25627b19 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= vba
-PORTVERSION= 1.6a
+PORTVERSION= 1.7
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,6 +20,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-profiling
USE_SDL= yes
WRKSRC= ${WRKDIR}/VisualBoyAdvance-${PORTVERSION}
@@ -35,32 +36,20 @@ CLAGS+=
DATA_FILES= ${WRKSRC}/src/VisualBoyAdvance.cfg
PROG_FILES= ${WRKSRC}/src/VisualBoyAdvance
-DOC_FILES= ${WRKSRC}/COPYING ${WRKSRC}/COPYRIGHT.TXT ${WRKSRC}/NEWS ${WRKSRC}/README
+DOC_FILES= ${WRKSRC}/COPYING ${WRKSRC}/AUTHORS ${WRKSRC}/NEWS ${WRKSRC}/README
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} "VisualBoyAdvance has the following tunable option(s):"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "--enable-gp enable GP32 emulation (default is NO)"
- @${ECHO_MSG} "--enable-c-core enable C core (default is YES)"
- @${ECHO_MSG} "--enable-dev enable development features (default is YES)"
- @${ECHO_MSG} "--with-mmx use MMX (default is NO)"
- @${ECHO_MSG} "--with-profiling enable profiling (default is YES)"
- @${ECHO_MSG} "--with-sdl-prefix=PFX Prefix where SDL is installed (optional)"
- @${ECHO_MSG} "--with-sdl-exec-prefix=PFX Exec prefix where SDL is installed (optional)"
- @${ECHO_MSG} "--disable-sdltest Do not try to compile and run a test SDL program"
- @${ECHO_MSG} "--with-x use the X Window System"
- @${ECHO_MSG} ""
@${ECHO_MSG} "GCC must be 3.x or greater in order to compile GBA.cpp with -O2. Earlier"
@${ECHO_MSG} "versions have a problem during optimization that requires an absurd"
@${ECHO_MSG} "ammount of memory and usually ends up crashing the compiler/computer"
@${ECHO_MSG} ""
@${ECHO_MSG} "Note by MAINTAINER: Currently everything < 500035 is being build with -O0"
- @${ECHO_MSG} "flag. The options above are untested and probably don't work"
+ @${ECHO_MSG} "flag."
@${ECHO_MSG} ""
-do-build:
- cd ${WRKSRC} && ${GMAKE}
+post-extract:
+ rm -rf `find ${WRKSRC} -name '.deps'`
do-install:
${INSTALL} -d ${TARGET_DIR} && \
@@ -68,7 +57,7 @@ do-install:
${INSTALL_DATA} ${DATA_FILES} ${TARGET_DIR} && \
post-install:
-.if !defined(NOPORTDOCS)
+.ifndef(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${DOC_FILES} ${DOCSDIR}
.endif
diff --git a/emulators/vba/distinfo b/emulators/vba/distinfo
index 8d2f21d72769..744192b0c3db 100644
--- a/emulators/vba/distinfo
+++ b/emulators/vba/distinfo
@@ -1 +1 @@
-MD5 (VisualBoyAdvance-src-1.6a.tar.gz) = 4ca771356a274d72b789e39011a1ba9c
+MD5 (VisualBoyAdvance-src-1.7.tar.gz) = 31a8665e90e84a079ab6664842083f55
diff --git a/emulators/vba/files/patch-aa b/emulators/vba/files/patch-aa
index 57d4bfd7c40e..39f0b8785d27 100644
--- a/emulators/vba/files/patch-aa
+++ b/emulators/vba/files/patch-aa
@@ -1,7 +1,7 @@
-*** src/SDL.cpp.orig Sat Aug 23 16:19:48 2003
---- src/SDL.cpp Tue Sep 2 17:59:39 2003
+*** src/SDL.cpp.orig Sun Jan 11 22:20:00 2004
+--- src/SDL.cpp Sun Jan 11 22:17:23 2004
***************
-*** 619,625 ****
+*** 625,631 ****
}
#else
#define SDL_CALL_STRETCHER \
@@ -9,7 +9,7 @@
#endif
#else
#define SDL_CALL_STRETCHER \
---- 619,625 ----
+--- 625,631 ----
}
#else
#define SDL_CALL_STRETCHER \
diff --git a/emulators/vba/files/patch-ab b/emulators/vba/files/patch-ab
index 112ce574c28d..6c8416155892 100644
--- a/emulators/vba/files/patch-ab
+++ b/emulators/vba/files/patch-ab
@@ -1,64 +1,103 @@
-*** configure.orig Sat Aug 23 16:20:50 2003
---- configure Fri Sep 5 01:50:01 2003
+*** configure.orig Sun Jan 11 22:22:03 2004
+--- configure Sun Jan 11 22:24:51 2004
***************
-*** 2726,2784 ****
+*** 5424,5521 ****
fi
-- echo $ac_n "checking for socklen_t""... $ac_c" 1>&6
-- echo "configure:2731: checking for socklen_t" >&5
-- cat > conftest.$ac_ext <<EOF
-- #line 2733 "configure"
-- #include "confdefs.h"
+- echo "$as_me:$LINENO: checking for socklen_t" >&5
+- echo $ECHO_N "checking for socklen_t... $ECHO_C" >&6
+- cat >conftest.$ac_ext <<_ACEOF
+- #line $LINENO "configure"
+- /* confdefs.h. */
+- _ACEOF
+- cat confdefs.h >>conftest.$ac_ext
+- cat >>conftest.$ac_ext <<_ACEOF
+- /* end confdefs.h. */
- #include <sys/socket.h>
- socklen_t x;
-
-- int main() {
+- int
+- main ()
+- {
-
-- ; return 0; }
-- EOF
-- if { (eval echo configure:2742: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
-- rm -rf conftest*
-- echo "$ac_t""yes" 1>&6
+- ;
+- return 0;
+- }
+- _ACEOF
+- rm -f conftest.$ac_objext
+- if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- echo "$as_me:$LINENO: result: yes" >&5
+- echo "${ECHO_T}yes" >&6
- else
-- echo "configure: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- rm -rf conftest*
--
-- cat > conftest.$ac_ext <<EOF
-- #line 2751 "configure"
-- #include "confdefs.h"
+- echo "$as_me: failed program was:" >&5
+- sed 's/^/| /' conftest.$ac_ext >&5
+-
+-
+- cat >conftest.$ac_ext <<_ACEOF
+- #line $LINENO "configure"
+- /* confdefs.h. */
+- _ACEOF
+- cat confdefs.h >>conftest.$ac_ext
+- cat >>conftest.$ac_ext <<_ACEOF
+- /* end confdefs.h. */
- #include <sys/socket.h>
- int accept (int, struct sockaddr *, size_t *);
-
-- int main() {
+- int
+- main ()
+- {
+-
+- ;
+- return 0;
+- }
+- _ACEOF
+- rm -f conftest.$ac_objext
+- if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+- (eval $ac_compile) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest.$ac_objext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
-
-- ; return 0; }
-- EOF
-- if { (eval echo configure:2760: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
-- rm -rf conftest*
--
-- echo "$ac_t""size_t" 1>&6
-- cat >> confdefs.h <<\EOF
+- echo "$as_me:$LINENO: result: size_t" >&5
+- echo "${ECHO_T}size_t" >&6
+- cat >>confdefs.h <<\_ACEOF
- #define socklen_t size_t
-- EOF
+- _ACEOF
-
- else
-- echo "configure: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- rm -rf conftest*
--
-- echo "$ac_t""int" 1>&6
-- cat >> confdefs.h <<\EOF
+- echo "$as_me: failed program was:" >&5
+- sed 's/^/| /' conftest.$ac_ext >&5
+-
+-
+- echo "$as_me:$LINENO: result: int" >&5
+- echo "${ECHO_T}int" >&6
+- cat >>confdefs.h <<\_ACEOF
- #define socklen_t int
-- EOF
+- _ACEOF
-
- fi
-- rm -f conftest*
+- rm -f conftest.$ac_objext conftest.$ac_ext
- fi
-- rm -f conftest*
+- rm -f conftest.$ac_objext conftest.$ac_ext
-
- echo $ac_n "checking whether byte ordering is bigendian""... $ac_c" 1>&6
- echo "configure:2784: checking whether byte ordering is bigendian" >&5
- if eval "test \"`echo '$''{'ac_cv_c_bigendian'+set}'`\" = set"; then
---- 2726,2731 ----
+ echo "$as_me:$LINENO: checking whether byte ordering is bigendian" >&5
+ echo $ECHO_N "checking whether byte ordering is bigendian... $ECHO_C" >&6
+ if test "${ac_cv_c_bigendian+set}" = set; then
+--- 5424,5429 ----
diff --git a/emulators/vba/pkg-plist b/emulators/vba/pkg-plist
index 45e54de7e477..bd5b9e730ae3 100644
--- a/emulators/vba/pkg-plist
+++ b/emulators/vba/pkg-plist
@@ -1,7 +1,7 @@
bin/VisualBoyAdvance
bin/VisualBoyAdvance.cfg
%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.TXT
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm share/doc/vba