aboutsummaryrefslogtreecommitdiff
path: root/emulators/vgba-bin/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-08-11 04:21:13 +0000
committerWill Andrews <will@FreeBSD.org>2000-08-11 04:21:13 +0000
commit1edbf4ebfe14b9baf26a01707d06d5333acafd4a (patch)
tree3ec44534c4fbb3db0a90da239ed2ae97d13efb84 /emulators/vgba-bin/Makefile
parent42fc0b021dc2f948e1b1bd186e3c94fc3edf79ec (diff)
downloadports-1edbf4ebfe14b9baf26a01707d06d5333acafd4a.tar.gz
ports-1edbf4ebfe14b9baf26a01707d06d5333acafd4a.zip
Notes
Diffstat (limited to 'emulators/vgba-bin/Makefile')
-rw-r--r--emulators/vgba-bin/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/emulators/vgba-bin/Makefile b/emulators/vgba-bin/Makefile
new file mode 100644
index 000000000000..3ca412216fc2
--- /dev/null
+++ b/emulators/vgba-bin/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: vgb-bin
+# Date created: 04 Aug 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= vgb
+PORTVERSION= 17
+CATEGORIES= emulators
+MASTER_SITES= http://www.komkon.org/fms/VGB/
+PKGNAMESUFFIX= -bin
+DISTNAME= VGB${PORTVERSION}-FreeBSD-80x86-bin
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= lioux@linf.unb.br
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+NO_BUILD= no
+WRKSRC= ${WRKDIR}/GB
+
+INSTALL_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS:="@comment "
+.else
+PLIST_SUB+= PORTDOCS:=
+.endif # !defined(NOPORTDOCS)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/vgb ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/vgb-debug ${PREFIX}/bin
+ @${INSTALL_DIR} ${PREFIX}/share/vgb
+ @${INSTALL_DATA} ${WRKSRC}/CART.GB ${PREFIX}/share/vgb
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DIR} ${PREFIX}/share/doc/vgb ${PREFIX}/share/doc/vgb/demos
+ @${INSTALL_DATA} ${WRKSRC}/VGB.html ${PREFIX}/share/doc/vgb
+ @for i in ${WRKSRC}/demos/* ; \
+ do \
+ ${INSTALL_DATA} $${i} ${PREFIX}/share/doc/vgb/demos ; \
+ done
+.endif # !defined(NOPORTDOCS)
+
+.include <bsd.port.mk>