aboutsummaryrefslogtreecommitdiff
path: root/emulators/vgba-bin
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-08-11 04:21:13 +0000
committerWill Andrews <will@FreeBSD.org>2000-08-11 04:21:13 +0000
commit1edbf4ebfe14b9baf26a01707d06d5333acafd4a (patch)
tree3ec44534c4fbb3db0a90da239ed2ae97d13efb84 /emulators/vgba-bin
parent42fc0b021dc2f948e1b1bd186e3c94fc3edf79ec (diff)
downloadports-1edbf4ebfe14b9baf26a01707d06d5333acafd4a.tar.gz
ports-1edbf4ebfe14b9baf26a01707d06d5333acafd4a.zip
Notes
Diffstat (limited to 'emulators/vgba-bin')
-rw-r--r--emulators/vgba-bin/Makefile45
-rw-r--r--emulators/vgba-bin/distinfo1
-rw-r--r--emulators/vgba-bin/pkg-comment1
-rw-r--r--emulators/vgba-bin/pkg-descr13
-rw-r--r--emulators/vgba-bin/pkg-plist20
5 files changed, 80 insertions, 0 deletions
diff --git a/emulators/vgba-bin/Makefile b/emulators/vgba-bin/Makefile
new file mode 100644
index 000000000000..3ca412216fc2
--- /dev/null
+++ b/emulators/vgba-bin/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: vgb-bin
+# Date created: 04 Aug 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= vgb
+PORTVERSION= 17
+CATEGORIES= emulators
+MASTER_SITES= http://www.komkon.org/fms/VGB/
+PKGNAMESUFFIX= -bin
+DISTNAME= VGB${PORTVERSION}-FreeBSD-80x86-bin
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= lioux@linf.unb.br
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+NO_BUILD= no
+WRKSRC= ${WRKDIR}/GB
+
+INSTALL_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS:="@comment "
+.else
+PLIST_SUB+= PORTDOCS:=
+.endif # !defined(NOPORTDOCS)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/vgb ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/vgb-debug ${PREFIX}/bin
+ @${INSTALL_DIR} ${PREFIX}/share/vgb
+ @${INSTALL_DATA} ${WRKSRC}/CART.GB ${PREFIX}/share/vgb
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DIR} ${PREFIX}/share/doc/vgb ${PREFIX}/share/doc/vgb/demos
+ @${INSTALL_DATA} ${WRKSRC}/VGB.html ${PREFIX}/share/doc/vgb
+ @for i in ${WRKSRC}/demos/* ; \
+ do \
+ ${INSTALL_DATA} $${i} ${PREFIX}/share/doc/vgb/demos ; \
+ done
+.endif # !defined(NOPORTDOCS)
+
+.include <bsd.port.mk>
diff --git a/emulators/vgba-bin/distinfo b/emulators/vgba-bin/distinfo
new file mode 100644
index 000000000000..686edaad2a21
--- /dev/null
+++ b/emulators/vgba-bin/distinfo
@@ -0,0 +1 @@
+MD5 (VGB17-FreeBSD-80x86-bin.tar.Z) = b6e20c5671fa0d5cd9dcddbd5806d694
diff --git a/emulators/vgba-bin/pkg-comment b/emulators/vgba-bin/pkg-comment
new file mode 100644
index 000000000000..f4aa475821eb
--- /dev/null
+++ b/emulators/vgba-bin/pkg-comment
@@ -0,0 +1 @@
+Nintendo GameBoy(tm) emulator (closed binary version of vgb)
diff --git a/emulators/vgba-bin/pkg-descr b/emulators/vgba-bin/pkg-descr
new file mode 100644
index 000000000000..c21d192d191f
--- /dev/null
+++ b/emulators/vgba-bin/pkg-descr
@@ -0,0 +1,13 @@
+Virtual Game Boy is the Nintendo GameBoy(tm) emulator on X-Window.
+
+ Test your VGB installation with the command(default):
+
+ vgb /usr/X11R6/share/vgb/CART.GB
+
+Virtual GameBoy (VGB) is a portable emulator of the Nintendo GameBoy
+handheld videogame console. It allows to run most of GameBoy software
+on a personal computer, as well as debug this software. As VGB is
+written in a portable C programming language, it runs on many
+different platforms and operating systems
+
+WWW: http://www.komkon.org/fms/VGB/
diff --git a/emulators/vgba-bin/pkg-plist b/emulators/vgba-bin/pkg-plist
new file mode 100644
index 000000000000..fb84f4abcffd
--- /dev/null
+++ b/emulators/vgba-bin/pkg-plist
@@ -0,0 +1,20 @@
+bin/vgb
+bin/vgb-debug
+share/vgb/CART.GB
+%%PORTDOCS:%%share/doc/vgb/VGB.html
+%%PORTDOCS:%%share/doc/vgb/demos/ANTS.gb
+%%PORTDOCS:%%share/doc/vgb/demos/DANLASER.gb
+%%PORTDOCS:%%share/doc/vgb/demos/PUZZLE.gb
+%%PORTDOCS:%%share/doc/vgb/demos/RPN.c
+%%PORTDOCS:%%share/doc/vgb/demos/RPN.gb
+%%PORTDOCS:%%share/doc/vgb/demos/SOUND.c
+%%PORTDOCS:%%share/doc/vgb/demos/SOUND.gb
+%%PORTDOCS:%%share/doc/vgb/demos/SPACE.gb
+%%PORTDOCS:%%share/doc/vgb/demos/SPACE.s
+%%PORTDOCS:%%share/doc/vgb/demos/SPRITE.c
+%%PORTDOCS:%%share/doc/vgb/demos/SPRITE.gb
+%%PORTDOCS:%%share/doc/vgb/demos/TEST.c
+%%PORTDOCS:%%share/doc/vgb/demos/TEST.gb
+%%PORTDOCS:%%@dirrm share/doc/vgb/demos
+%%PORTDOCS:%%@dirrm share/doc/vgb
+@dirrm share/vgb