aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-12-03 20:07:52 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-12-03 20:07:52 +0000
commit5053e194575c091097df0dceeeeaab4e96323e61 (patch)
tree284d996068c091c2651953387c2a79418fbaf4cc /emulators/vice/Makefile
parent3986ac7c82869bdea9b30687920f5cbf6e5a8014 (diff)
downloadports-5053e194575c091097df0dceeeeaab4e96323e61.tar.gz
ports-5053e194575c091097df0dceeeeaab4e96323e61.zip
Notes
Diffstat (limited to 'emulators/vice/Makefile')
-rw-r--r--emulators/vice/Makefile42
1 files changed, 35 insertions, 7 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 66483d33c576..41ca72bb744f 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= vice
-PORTVERSION= 1.17
+PORTVERSION= 1.18
CATEGORIES= emulators
MASTER_SITES= http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
ftp://ftp.zimmers.net/pub/cbm/crossplatform/emulators/VICE/
@@ -14,8 +14,9 @@ PKGNAMESUFFIX?= ${GNOME_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Emulator for Commodore's C64, C128, VIC20, PET, and CBM-II
+LIB_DEPENDS= png:${PORTSDIR}/graphics/png
.if !defined(VICE_WITH_GNOME)
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
.endif
RESTRICTED= ROMs are copyrighted by Commodore Business Machines
@@ -35,6 +36,10 @@ CONFIGURE_ARGS= --with-xaw3d
CONFLICTS?= vice-gnome-1.*
.endif
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INFO= vice
MAN1= vice.1 c1541.1 petcat.1
MLINKS= vice.1 x64.1 \
@@ -44,11 +49,37 @@ MLINKS= vice.1 x64.1 \
vice.1 xplus4.1 \
vice.1 xcbm2.1
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/include/esd.h) && !defined(WITHOUT_ESOUND)
+WITH_ESOUND?=yes
+.endif
+
+# will be picked up by configure
+.if exists(${LOCALBASE}/include/ffmpeg/avformat.h)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+LIBS+= -lgettextlib
+.else
+CONFIGURE_ARGS+= --disable-nls
+.endif
+
.if !defined(WITHOUT_SDL)
-USE_SDL= sdl
+USE_SDL= sdl
+CONFIGURE_ARGS+= --with-sdl
+CFLAGS+= -DHAVE_LIBSDL=1 -DHAVE_SDL_SDL_AUDIO_H=1
+CPPFLAGS+= -I${LOCALBASE}/include/SDL11
.endif
-.include <bsd.port.pre.mk>
+.if defined(WITH_ESOUND)
+LIB_DEPENDS+= esd.2:${PORTSDIR}/audio/esound
+CFLAGS+= -DHAVE_LIBESD=1 -DHAVE_SDL_SDL_AUDIO_H=1
+.else
+CONFIGURE_ARGS+= --without-esd
+.endif
.if ${X_WINDOW_SYSTEM:L} != xfree86-3
BUILD_DEPENDS+= bdftopcf:${X_CLIENTS_PORT}
@@ -65,9 +96,6 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/man/vice.1
- ${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG}|g" \
- -e "s|l-lesd|${SDL_CONFIG}|g" \
- ${WRKSRC}/configure
pre-install:
${MKDIR} ${DOCSDIR} ${PREFIX}/lib/vice/fonts