aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-01-07 10:04:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-01-07 10:04:00 +0000
commit710f3c39622e692dd689ead77cb190c240de6be0 (patch)
tree3c92230fd5fb22baa20eb70d38f12ac6904d1869 /emulators/vice/Makefile
parentca60622765a7a02342ab081277bec1a8f06b9e48 (diff)
downloadports-710f3c39622e692dd689ead77cb190c240de6be0.tar.gz
ports-710f3c39622e692dd689ead77cb190c240de6be0.zip
Notes
Diffstat (limited to 'emulators/vice/Makefile')
-rw-r--r--emulators/vice/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 6ee7f0c38aff..f57591dc9839 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -79,7 +79,7 @@ INFO= vice
LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
.endif
.else
-CONFIGURE_ARGS+= --disable-libusb
+CONFIGURE_ARGS+= --disable-libusb
.endif
.if exists(${LOCALBASE}/bin/fc-cache)
@@ -101,6 +101,8 @@ LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls --localedir=${LOCALBASE}/share/locale
+# causes vice to crash:
#LDFLAGS+= -lgettextlib
PLIST_SUB+= NLS=""
.else
@@ -131,8 +133,15 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/man/vice.1
+ ${REINPLACE_CMD} -e "s|^localedir.*|localedir = ${LOCALBASE}/share/locale|" \
+ ${WRKSRC}/po/Makefile.in.in
${REINPLACE_CMD} -e 's|lungif|lgif|g' -e 's|== "x|= "x|' \
+ -e 's|"DATADIRNAME"/locale|share/locale|' \
${WRKSRC}/configure
+.for i in da.po de.po fr.po hu.po it.po nl.po pl.po sv.po tr.po
+ ${MV} "${WRKSRC}/po/${i}" "${WRKSRC}/po/${i}.latin"
+ ${LOCALBASE}/bin/iconv -f latin1 -t utf-8 < "${WRKSRC}/po/${i}.latin" > "${WRKSRC}/po/${i}"
+.endfor
.if defined(NOPORTDOCS)
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in
.endif