aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-06-12 14:50:13 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-06-12 14:50:13 +0000
commit058acba2d6130826a0f208fed7604b2d6a7a8878 (patch)
treeacedde76a0fe09bfb3acb2917e75b14931b7e5e0 /emulators/vice
parent9fd05576c742cac21e6994d93eadd3098175228d (diff)
downloadports-058acba2d6130826a0f208fed7604b2d6a7a8878.tar.gz
ports-058acba2d6130826a0f208fed7604b2d6a7a8878.zip
Notes
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile2
-rw-r--r--emulators/vice/files/patch-xorg22
2 files changed, 23 insertions, 1 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index db05a743dbd4..fbc0cfc7598d 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -6,7 +6,7 @@
PORTNAME= vice
PORTVERSION= 1.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
http://fresh.t-systems-sfr.com/linux/src/ \
diff --git a/emulators/vice/files/patch-xorg b/emulators/vice/files/patch-xorg
new file mode 100644
index 000000000000..6ced0d1e1e33
--- /dev/null
+++ b/emulators/vice/files/patch-xorg
@@ -0,0 +1,22 @@
+--- src/arch/unix/x11/xaw/uicolor.c 2003-06-24 15:17:32.000000000 +0200
++++ vice-1.20.pigi4/src/arch/unix/x11/xaw/uicolor.c 2007-04-08 22:58:25.000000000 +0200
+@@ -121,7 +121,7 @@
+ /* This is a kludge to map pixels to zimage values. Is there a better
+ way to do this? //tvr */
+ im = XCreateImage(display, visual, x11ui_get_display_depth(),
+- ZPixmap, 0, (char *)data, 1, 1, 8, 1);
++ ZPixmap, 0, (char *)data, 1, 1, 8, 0);
+ if (!im) {
+ log_error(LOG_DEFAULT, _("XCreateImage failed."));
+ free(data);
+--- src/arch/unix/x11/gnome/uicolor.c 2006-07-22 18:28:40.000000000 +0200
++++ vice-1.20.pigi4/src/arch/unix/x11/gnome/uicolor.c 2007-04-08 22:58:26.000000000 +0200
+@@ -167,7 +167,7 @@
+ way to do this? //tvr */
+ im = XCreateImage(display, GDK_VISUAL_XVISUAL(visual),
+ x11ui_get_display_depth(),
+- ZPixmap, 0, (char *)data, 1, 1, 8, 1);
++ ZPixmap, 0, (char *)data, 1, 1, 8, 0);
+ if (!im) {
+ log_error(LOG_DEFAULT, _("XCreateImage failed."));
+ free(data);