aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-03-04 09:09:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-03-04 09:09:59 +0000
commitaf1655f60576f79fa92a6007472d5665fe6c27ef (patch)
tree2e2bf6941c8af244f6e77ba888b0ce8c445a0a75 /emulators/vice
parent213ea1a511a6b527e92646d2d468b43082321a02 (diff)
downloadports-af1655f60576f79fa92a6007472d5665fe6c27ef.tar.gz
ports-af1655f60576f79fa92a6007472d5665fe6c27ef.zip
Notes
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile4
-rw-r--r--emulators/vice/files/patch-joy.c11
-rw-r--r--emulators/vice/files/patch-joy_usb.c10
-rw-r--r--emulators/vice/pkg-message10
4 files changed, 34 insertions, 1 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 909e681c9d14..28dd49e97a42 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -6,7 +6,7 @@
PORTNAME= vice
PORTVERSION= 1.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
http://fresh.t-systems-sfr.com/linux/src/ \
@@ -101,6 +101,8 @@ post-extract:
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/man/vice.1
+ ${REINPLACE_CMD} -e "s|machine/joystick.h|sys/joystick.h|g" \
+ ${WRKSRC}/configure
.if defined(NOPORTDOCS)
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in
.endif
diff --git a/emulators/vice/files/patch-joy.c b/emulators/vice/files/patch-joy.c
new file mode 100644
index 000000000000..a6dbfc692f59
--- /dev/null
+++ b/emulators/vice/files/patch-joy.c
@@ -0,0 +1,11 @@
+--- src/arch/unix/joy.c.orig Tue Feb 20 10:11:02 2007
++++ src/arch/unix/joy.c Tue Feb 20 10:11:13 2007
+@@ -117,7 +117,7 @@
+ #endif
+
+ #elif defined(BSD_JOYSTICK)
+-#include <machine/joystick.h>
++#include <sys/joystick.h>
+ #define JS_DATA_TYPE joystick
+ #define JS_RETURN sizeof(struct joystick)
+ int use_old_api=1;
diff --git a/emulators/vice/files/patch-joy_usb.c b/emulators/vice/files/patch-joy_usb.c
new file mode 100644
index 000000000000..49f4327cdd7c
--- /dev/null
+++ b/emulators/vice/files/patch-joy_usb.c
@@ -0,0 +1,10 @@
+--- src/arch/unix/joy_usb.c.orig Tue Feb 20 10:11:57 2007
++++ src/arch/unix/joy_usb.c Tue Feb 20 10:12:37 2007
+@@ -50,6 +50,7 @@
+
+ extern log_t joystick_log;
+
++#include <sys/ioccom.h>
+ #include <dev/usb/usb.h>
+ #include <dev/usb/usbhid.h>
+ #include <errno.h>
diff --git a/emulators/vice/pkg-message b/emulators/vice/pkg-message
new file mode 100644
index 000000000000..9cfcff5b5c8d
--- /dev/null
+++ b/emulators/vice/pkg-message
@@ -0,0 +1,10 @@
+The VICE port can use /dev/joy* for joystick support for video games. To enable
+the joystick port, add
+
+joy_load="YES" to /boot/loader.conf
+
+and the following lines to /etc/devfs.conf (for additional joysticks use
+/dev/joy1, /dev/joy2 etc.) :
+
+own /dev/joy0 root:wheel
+perm /dev/joy0 0666