aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
commitbc62127a69294fd3340ea793685953d98ff835dc (patch)
treed124c4d6f965d5152806ebfbf40e1b5a25860ddb /emulators/vice
parente8dd5f52410bdf2a989023706699373d47296008 (diff)
downloadports-bc62127a69294fd3340ea793685953d98ff835dc.tar.gz
ports-bc62127a69294fd3340ea793685953d98ff835dc.zip
Notes
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 7166666892db..3c90ef7433fe 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -85,14 +85,10 @@ FIX_XAW= src/arch/unix/x11/xaw/about.c \
src/arch/unix/x11/xaw/widgets/MultiListP.h \
src/arch/unix/x11/xaw/widgets/ScrList.c \
-.if !defined(NOPORTDOCS)
-INFO= vice
-.endif
+.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION}<800063
-LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.if ${PORT_OPTIONS:MDOCS}
+INFO= vice
.endif
.if exists(${LOCALBASE}/bin/fc-cache)
@@ -108,9 +104,9 @@ PLIST_SUB+= NOFCCACHE=""
LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PATCH_DEPENDS+= ${LOCALBASE}/bin/iconv:${PORTSDIR}/converters/libiconv
-USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls --localedir=${LOCALBASE}/share/locale
# causes vice to crash:
#LDFLAGS+= -lgettextlib
@@ -145,10 +141,10 @@ post-patch:
${MV} "${WRKSRC}/po/${i}" "${WRKSRC}/po/${i}.latin"
${LOCALBASE}/bin/iconv -f latin1 -t utf-8 < "${WRKSRC}/po/${i}.latin" > "${WRKSRC}/po/${i}"
.endfor
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's| doc||' ${WRKSRC}/Makefile.in
.endif
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
.if defined(VICE_WITH_XAW3D)
.for i in ${FIX_XAW}
${REINPLACE_CMD} -e 's|X11/Xaw/|X11/Xaw3d/|' ${WRKSRC}/${i}
@@ -157,7 +153,7 @@ post-patch:
.endif
pre-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.endif
${MKDIR} ${PREFIX}/lib/vice/fonts
@@ -165,8 +161,8 @@ pre-install:
${PREFIX}/lib/vice/fonts/
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${LN} -sf vice_toc.html ${DOCSDIR}/index.html
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>