aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-kmod-legacy/Makefile
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2009-10-23 14:29:50 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2009-10-23 14:29:50 +0000
commitf9297d2f2bf3976db9e172235347c2016414ccc6 (patch)
tree208ca47ad913db4a8f44c6c34b50114d753da2d2 /emulators/virtualbox-ose-kmod-legacy/Makefile
parentbb8fa633fe25f40ffb09bb29f969e3b993e20b4a (diff)
Notes
Diffstat (limited to 'emulators/virtualbox-ose-kmod-legacy/Makefile')
-rw-r--r--emulators/virtualbox-ose-kmod-legacy/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/emulators/virtualbox-ose-kmod-legacy/Makefile b/emulators/virtualbox-ose-kmod-legacy/Makefile
index 94377f31fbcd..d0419e2d0b6f 100644
--- a/emulators/virtualbox-ose-kmod-legacy/Makefile
+++ b/emulators/virtualbox-ose-kmod-legacy/Makefile
@@ -76,6 +76,14 @@ KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS=
+.if defined(WITHOUT_QT4) && !defined(WITHOUT_NLS)
+BROKEN= NLS support requires QT4 frontend. Run 'make config' again!
+.endif
+
+.if defined(WITHOUT_X11) && !defined(WITHOUT_QT4)
+BROKEN= QT4 frontend requires X11 support. Run 'make config' again!
+.endif
+
.if !defined(WITHOUT_X11)
USE_SDL= sdl
USE_XORG= xcursor xmu
@@ -96,7 +104,6 @@ PLIST_SUB+= QT4=""
.else
CONFIGURE_ARGS+=--disable-qt4
PLIST_SUB+= QT4="@comment "
-WITHOUT_NLS= yes
.endif
.if defined(WITH_GUESTADDITIONS)