aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2018-11-29 21:09:25 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2018-11-29 21:09:25 +0000
commit085b666fecc9a448fe9ee53ac07a8964997a6ce5 (patch)
treef539a3eee557c06c33e693919ebad3f692a7f9a3 /emulators/virtualbox-ose
parentcdd57836e9ab4bfaa3dd11196cb1eb6248aa2401 (diff)
downloadports-085b666fecc9a448fe9ee53ac07a8964997a6ce5.tar.gz
ports-085b666fecc9a448fe9ee53ac07a8964997a6ce5.zip
Notes
Diffstat (limited to 'emulators/virtualbox-ose')
-rw-r--r--emulators/virtualbox-ose/Makefile1
-rw-r--r--emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp21
2 files changed, 22 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index ef351a835a51..6cc0c361f9b0 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -3,6 +3,7 @@
PORTNAME= virtualbox-ose
PORTVERSION= 5.2.22
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${PORTVERSION}/
DISTFILES= VirtualBox-${PORTVERSION}${EXTRACT_SUFX} ${GUESTADDITIONS}
diff --git a/emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp b/emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp
new file mode 100644
index 000000000000..3dbdc120801a
--- /dev/null
+++ b/emulators/virtualbox-ose/files/patch-src_VBox_Main_src-client_ConsoleImpl.cpp
@@ -0,0 +1,21 @@
+--- src/VBox/Main/src-client/ConsoleImpl.cpp.orig 2018-11-08 19:42:03 UTC
++++ src/VBox/Main/src-client/ConsoleImpl.cpp
+@@ -9859,7 +9859,7 @@ void Console::i_powerUpThreadTask(VMPowerUpTask *pTask
+
+ alock.acquire();
+
+- /* Enable client connections to the server. */
++ /* Enable client connections to the VRDP server. */
+ pConsole->i_consoleVRDPServer()->EnableConnections();
+
+ #ifdef VBOX_WITH_AUDIO_VRDE
+@@ -9876,9 +9876,6 @@ void Console::i_powerUpThreadTask(VMPowerUpTask *pTask
+ pConsole->mAudioVRDE->doAttachDriverViaEmt(pConsole->mpUVM, &alock);
+ }
+ #endif
+-
+- /* Enable client connections to the VRDP server. */
+- pConsole->i_consoleVRDPServer()->EnableConnections();
+
+ #ifdef VBOX_WITH_VIDEOREC
+ BOOL fVideoRecEnabled = FALSE;