aboutsummaryrefslogtreecommitdiff
path: root/emulators/wahcade/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-03-05 09:47:15 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-03-05 09:47:15 +0000
commit876be751dff8dbadb9ff2cf95eca1bad7c45a410 (patch)
treecdef32a4de30cefd1c9b2e7a0b73e44d90f73e1a /emulators/wahcade/Makefile
parentf5a409d7cb404df3af994e00fa07c42dc7e6ded9 (diff)
Notes
Diffstat (limited to 'emulators/wahcade/Makefile')
-rw-r--r--emulators/wahcade/Makefile105
1 files changed, 40 insertions, 65 deletions
diff --git a/emulators/wahcade/Makefile b/emulators/wahcade/Makefile
index 6ce3e6c06c22..754e5327577d 100644
--- a/emulators/wahcade/Makefile
+++ b/emulators/wahcade/Makefile
@@ -5,87 +5,62 @@
# $FreeBSD$
#
-PORTNAME= wahcade
-PORTVERSION= 0.11
-CATEGORIES= emulators
-MASTER_SITES= http://www.anti-particle.com/projects/wahcade/
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+PORTNAME= wahcade
+PORTVERSION= 0.16
+CATEGORIES= emulators
+MASTER_SITES= http://www.anti-particle.com/projects/wahcade/
-MAINTAINER= robb_force@holybuffalo.net
-COMMENT= A frontend for almost any emulator (MameWAH clone)
+MAINTAINER= robb_force@holybuffalo.net
+COMMENT= A frontend for almost any emulator (MameWAH clone)
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk2 \
- ${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ ${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_PYTHON= 2.4+
-NO_BUILD= yes
-OPTIONS= MPLAYER "For movie playback." off
-# Bypass infrasructure bug (taken from www/py-turbogears)
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-BINDIR= ${PREFIX}/bin
+USE_PYTHON= 2.4+
+WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
+OPTIONS= MPLAYER "Install mplayer for movie playback" off \
+ PSYCHO "Enable psycho optimization" on
-.if ${ARCH} != "i386"
-WITHOUT_PSYCO= yes
-.endif
+SUB_FILES= pkg-message
-# required for PSYCO
-.ifndef(WITHOUT_PSYCO)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
-.endif
+.include <bsd.port.pre.mk>
.if defined(WITH_MPLAYER)
-RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
-pre-everything::
-.ifndef(WITHOUT_PSYCO)
- @${ECHO_MSG} '===> Define WITHOUT_PSYCO to disable devel/py-psyco optimization'
+.if !defined(WITHOUT_PSYCHO) && ${ARCH} == "i386"
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
-# setup.py seems to be for windows, so run the patched install script
-do-install:
- #wahcade start script
- echo "#!${BINDIR}/bash" > ${BINDIR}/${PORTNAME}
- echo "cd ${DATADIR}" >> ${BINDIR}/${PORTNAME}
- echo "python ${PORTNAME} \$*" >> ${BINDIR}/${PORTNAME}
- ${CHMOD} 755 ${BINDIR}/${PORTNAME}
-
- #install files
- ${INSTALL} -d -v ${DATADIR}
- ${INSTALL} -m 644 ${WRKSRC}/*.py ${DATADIR}
- ${INSTALL} -m 755 ${WRKSRC}/${PORTNAME} ${DATADIR}
- ${INSTALL} -d -v ${DATADIR}/config.dist
- ${INSTALL} -d -v ${DATADIR}/config.dist/ctrlr
- ${INSTALL} -d -v ${DATADIR}/config.dist/files
- ${INSTALL} -d -v ${DATADIR}/config.dist/ini
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/classic\ 640x480
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/classic\ 800x600
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/classic\ 1024x768
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/cpviewer
- ${INSTALL} -d -v ${DATADIR}/pixmaps
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/*.ini ${DATADIR}/config.dist
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/ctrlr/*.ini ${DATADIR}/config.dist/ctrlr
- #${INSTALL} -m 644 ${WRKSRC}/config.dist/files/* ${DATADIR}/config.dist/files
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/ini/*.ini ${DATADIR}/config.dist/ini
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/classic\ 640x480/* ${DATADIR}/config.dist/layouts/classic\ 640x480
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/classic\ 800x600/* ${DATADIR}/config.dist/layouts/classic\ 800x600
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/classic\ 1024x768/* ${DATADIR}/config.dist/layouts/classic\ 1024x768
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/cpviewer/* ${DATADIR}/config.dist/layouts/cpviewer
- ${INSTALL} -m 644 ${WRKSRC}/pixmaps/*.png ${DATADIR}/pixmaps
+do-build:
+ @(${ECHO_CMD} "#!${SH}"; \
+ ${ECHO_CMD} "cd ${DATADIR} || exit 1"; \
+ ${ECHO_CMD} 'exec ${PYTHON_CMD} ${PORTNAME}.py "$$@"') \
+ > ${WRKSRC}/${PORTNAME}
- #compile everything python
- ${PYTHON_CMD} -c "import compileall; compileall.compile_dir('${DATADIR}')"
-
-post-install:
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for f in *.py config.dist glade locale pixmaps templates
+ ${CP} -R ${WRKSRC}/${f} ${DATADIR}
+.endfor
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop \
+ ${PREFIX}/share/applications
+ @${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
+ @${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
+ @${FIND} ${DOCSDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
+ @${FIND} ${DOCSDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
.endif
+
+post-install:
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
.include <bsd.port.post.mk>