aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2008-06-15 10:59:43 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2008-06-15 10:59:43 +0000
commit03aa7a90a21cf1ea8cc0bab479be02901fc9ca4a (patch)
treee30b1330e6b528f4c201f575bef571dbb47a872a /emulators/wine/Makefile
parent392cae5b0d468f39bef111269c629698540bd002 (diff)
downloadports-03aa7a90a21cf1ea8cc0bab479be02901fc9ca4a.tar.gz
ports-03aa7a90a21cf1ea8cc0bab479be02901fc9ca4a.zip
Notes
Diffstat (limited to 'emulators/wine/Makefile')
-rw-r--r--emulators/wine/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index d00a9e75a616..93b91117d5ef 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.0-rc4
+DISTVERSION= 1.0-rc5
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SFE \
@@ -41,7 +41,8 @@ USE_XORG= xpm
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On
+OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
+ HAL "Use HAL (Hardware Abstraction Layer)" Off
.include <bsd.port.pre.mk>
@@ -52,6 +53,13 @@ CONFIGURE_ARGS+= --with-cups
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
.endif
+.ifdef WITH_HAL
+CONFIGURE_ARGS+= --with-hal
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.else
+CONFIGURE_ARGS+= --without-hal
+.endif
+
.if ${OSVERSION} < 602000
IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif
@@ -59,6 +67,7 @@ IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to proble
post-patch:
.if ${OSVERSION} < 700041
${REINPLACE_CMD} 's/-lpthread/-lthr/g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} '/ac_hal_libs=/s/"$$/ -lthr"/' ${WRKSRC}/configure
.endif
pre-build: