aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2010-01-09 19:12:55 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2010-01-09 19:12:55 +0000
commit226e27a98a99eb69b243b61bbcaeb170103e5db5 (patch)
treef06c285cc048241ba1695604f99440d529388741 /emulators/wine/Makefile
parent2200fda13f6e7061e9425bd92fdd3a93865dfab9 (diff)
downloadports-226e27a98a99eb69b243b61bbcaeb170103e5db5.tar.gz
ports-226e27a98a99eb69b243b61bbcaeb170103e5db5.zip
Notes
Diffstat (limited to 'emulators/wine/Makefile')
-rw-r--r--emulators/wine/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 7093c029dbe3..48eb26325d62 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -16,6 +16,7 @@ MASTER_SITES= SF/${PORTNAME}/Source \
MAINTAINER= gerald@FreeBSD.org
COMMENT= Microsoft Windows compatibility layer for Unix-like systems
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/devel/flex
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.10:${PORTSDIR}/graphics/jpeg \
@@ -29,7 +30,8 @@ CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
--without-gsm --without-mpg123 --without-openal \
--without-sane --without-xcursor
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ FLEX="${LOCALBASE}/bin/flex"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
MAKE_JOBS_SAFE= yes
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \