aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2005-11-24 00:15:55 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2005-11-24 00:15:55 +0000
commitce296c18228231cd61a77c05e1c78d63fa38ac5d (patch)
treebb1a497bf86a2e3486d58e3436395ebf2219d2ef /emulators/wine/Makefile
parent23fc9501e31cab6474af04d4f7a15df847f01df9 (diff)
downloadports-ce296c18228231cd61a77c05e1c78d63fa38ac5d.tar.gz
ports-ce296c18228231cd61a77c05e1c78d63fa38ac5d.zip
Notes
Diffstat (limited to 'emulators/wine/Makefile')
-rw-r--r--emulators/wine/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 1975292922c9..24a645dd38cd 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.2
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= http://ibiblio.org/pub/linux/system/emulators/wine/ \
@@ -33,16 +33,15 @@ USE_GL= yes
USE_MESA= yes # wine/dlls/glut32/ depends on the presence of libglut.
USE_XPM= yes
+SUB_FILES= pkg-message wine.sh
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 503000
IGNORE= fails to work on versions of FreeBSD before 5.3 (due to problems with threading support)
.endif
-post-extract:
- @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/wine.sh \
- > ${WRKSRC}/wine.sh
-
pre-build:
cd ${WRKSRC} && make depend
@@ -60,8 +59,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${DOCSDIR}/README.winedump
.endif
@${INSTALL_SCRIPT} ${WRKSRC}/tools/bug_report.pl ${PREFIX}/lib/wine
- @${INSTALL_SCRIPT} ${WRKSRC}/wine.sh ${PREFIX}/etc/rc.d/000.wine.sh
- ${ECHO}
- @${SED} s+%%PREFIX%%+${PREFIX}+g <${PKGMESSAGE}
+ @${INSTALL_SCRIPT} ${WRKDIR}/wine.sh ${PREFIX}/etc/rc.d/000.wine.sh
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>