aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2003-12-28 13:16:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2003-12-28 13:16:21 +0000
commitb96c82c80a3f3ec857a93da0bf00cfdcf05652fd (patch)
tree07ba266cd060b4c17ffd4e9227915c78d9f8b46c /emulators/wine
parentb1b69ea46cea514b97f9c1342929971ac17a1116 (diff)
downloadports-b96c82c80a3f3ec857a93da0bf00cfdcf05652fd.tar.gz
ports-b96c82c80a3f3ec857a93da0bf00cfdcf05652fd.zip
Notes
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile2
-rw-r--r--emulators/wine/files/patch-dlls::winmm::wineoss::audio.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 7396a93218f0..5088eab14e8f 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -8,7 +8,7 @@
PORTNAME= wine
PORTVERSION= 20031212
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= ALPHA/wine/development
diff --git a/emulators/wine/files/patch-dlls::winmm::wineoss::audio.c b/emulators/wine/files/patch-dlls::winmm::wineoss::audio.c
new file mode 100644
index 000000000000..cb6a286c8700
--- /dev/null
+++ b/emulators/wine/files/patch-dlls::winmm::wineoss::audio.c
@@ -0,0 +1,24 @@
+Index: dlls/winmm/wineoss/audio.c
+===================================================================
+RCS file: /home/wine/wine/dlls/winmm/wineoss/audio.c,v
+retrieving revision 1.108
+diff -u -3 -p -r1.108 audio.c
+--- dlls/winmm/wineoss/audio.c 12 Dec 2003 05:55:26 -0000 1.108
++++ dlls/winmm/wineoss/audio.c 28 Dec 2003 12:46:50 -0000
+@@ -544,10 +544,15 @@ static BOOL OSS_WaveOutInit(OSS_DEVICE*
+ strncpy(ossdev->out_caps.szPname, info.name, sizeof(info.name));
+ TRACE("%s\n", ossdev->ds_desc.szDesc);
+ } else {
+- ERR("%s: can't read info!\n", ossdev->mixer_name);
++ ERR("%s: cannot read SOUND_MIXER_INFO!\n", ossdev->mixer_name);
++#ifndef __FreeBSD__
++ /* FreeBSD up to at least 5.2 provides this ioctl, but does
++ * implement it properly, so ignore errors on that platform.
++ */
+ OSS_CloseDevice(ossdev);
+ close(mixer);
+ return FALSE;
++#endif
+ }
+ } else {
+ ERR("%s: %s\n", ossdev->mixer_name , strerror( errno ));