aboutsummaryrefslogtreecommitdiff
path: root/emulators/winetricks
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-11-07 10:12:59 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-11-07 10:12:59 +0000
commitba3cbe63693aa49d032c058d6d2e3ad26a175cb9 (patch)
tree24d3967dffeba49ce8676e0514af32f51e587ebd /emulators/winetricks
parentfc590f37722467bcd34455700df41566f91929b9 (diff)
downloadports-ba3cbe63693aa49d032c058d6d2e3ad26a175cb9.tar.gz
ports-ba3cbe63693aa49d032c058d6d2e3ad26a175cb9.zip
Notes
Diffstat (limited to 'emulators/winetricks')
-rw-r--r--emulators/winetricks/Makefile30
-rw-r--r--emulators/winetricks/distinfo3
-rw-r--r--emulators/winetricks/pkg-descr7
-rw-r--r--emulators/winetricks/pkg-message2
4 files changed, 42 insertions, 0 deletions
diff --git a/emulators/winetricks/Makefile b/emulators/winetricks/Makefile
new file mode 100644
index 000000000000..cd839ab1e2b9
--- /dev/null
+++ b/emulators/winetricks/Makefile
@@ -0,0 +1,30 @@
+# Created by: Nikolai Lifanov <lifanov@mail.lifanov.com>
+# $FreeBSD$
+
+PORTNAME= winetricks
+PORTVERSION= 20161012
+CATEGORIES= emulators
+
+MAINTAINER= lifanov@mail.lifanov.com
+COMMENT= Easy way to work around problems in Wine
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/src/COPYING
+
+.if !defined(WITHOUT_X11)
+RUN_DEPENDS= zenity>0:x11/zenity
+.endif
+
+USE_GITHUB= yes
+GH_ACCOUNT= Winetricks
+
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_FILES= bin/winetricks man/man1/winetricks.1.gz
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/winetricks ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/src/winetricks.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/emulators/winetricks/distinfo b/emulators/winetricks/distinfo
new file mode 100644
index 000000000000..75ff04498d9c
--- /dev/null
+++ b/emulators/winetricks/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476286164
+SHA256 (Winetricks-winetricks-20161012_GH0.tar.gz) = 094ecc82178bb2b6875e29927df068a1d7c114868ec86d5517e26e0214030f6f
+SIZE (Winetricks-winetricks-20161012_GH0.tar.gz) = 175820
diff --git a/emulators/winetricks/pkg-descr b/emulators/winetricks/pkg-descr
new file mode 100644
index 000000000000..31426bbfd654
--- /dev/null
+++ b/emulators/winetricks/pkg-descr
@@ -0,0 +1,7 @@
+Winetricks is an easy way to work around problems in Wine.
+
+It has a menu of supported games/apps for which it can do
+all the workarounds automatically. It also lets you install
+missing DLLs or tweak various Wine settings individually.
+
+WWW: https://wiki.winehq.org/Winetricks
diff --git a/emulators/winetricks/pkg-message b/emulators/winetricks/pkg-message
new file mode 100644
index 000000000000..b8983de3075b
--- /dev/null
+++ b/emulators/winetricks/pkg-message
@@ -0,0 +1,2 @@
+This port requires one of the wine ports installed.
+Please pick between wine, wine-devel, or wine-staging.