aboutsummaryrefslogtreecommitdiff
path: root/emulators/xcpc/Makefile
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-31 04:21:34 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-31 04:21:34 +0000
commitc013f5d1d23fd987efe7c304fe9835c25219e256 (patch)
treedcae327ce3410e16d4486a3c50a5d9e89d7a4a43 /emulators/xcpc/Makefile
parent0efa09b788409fa3e5640d76c98573614263becd (diff)
downloadports-c013f5d1d23fd987efe7c304fe9835c25219e256.tar.gz
ports-c013f5d1d23fd987efe7c304fe9835c25219e256.zip
Notes
Diffstat (limited to 'emulators/xcpc/Makefile')
-rw-r--r--emulators/xcpc/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
new file mode 100644
index 000000000000..80f2d4bc9a0d
--- /dev/null
+++ b/emulators/xcpc/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: cpmtools
+# Date created: 31 January 2008
+# Whom: joerg
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcpc
+PORTVERSION= 20070122
+CATEGORIES= emulators
+MASTER_SITES= SF
+
+MAINTAINER= pixel@hugbox.org
+COMMENT= A portable Amstrad 464&/664/6128 emulator
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+
+USE_XORG= ice
+USE_GNOME= pkgconfig glib20
+USE_ICONV= yes
+USE_GETTEXT= yes
+
+LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu \
+ pcre.0:${PORTSDIR}/devel/pcre \
+ dsk.5:${PORTSDIR}/emulators/libdsk
+
+OPTIONS= MOTIF "With Motif widget set" on \
+ ATHENA "With Athen widget set" off \
+ XSHM "With XShm support" on \
+ DEBUG "Turn debugging on" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.else
+CONFIGURE_ARGS+=--disable-debug
+.endif
+
+.if defined(WITH_XSHM)
+CONFIGURE_ARGS+=--enable-xshm
+.else
+CONFIGURE_ARGS+=--disable-xshm
+.endif
+
+.if defined(WITH_MOTIF)
+USE_MOTIF=yes
+CONFIGURE_ARGS+=--with-motif1
+.else
+CONFIGURE_ARGS+=--without-motif1
+.endif
+
+.if defined(WITH_ATHENA)
+LIB_DEPENDS+= Xaw.8:${PORTSDIR}/x11-toolkits/libXaw
+CONFIGURE_ARGS+=--with-athena
+.else
+CONFIGURE_ARGS+=--without-athena
+.endif
+
+.include <bsd.port.post.mk>