aboutsummaryrefslogtreecommitdiff
path: root/emulators/xen-kernel
diff options
context:
space:
mode:
authorRoger Pau Monné <royger@FreeBSD.org>2015-06-19 10:41:31 +0000
committerRoger Pau Monné <royger@FreeBSD.org>2015-06-19 10:41:31 +0000
commitc5fa7de8737f5252c4cedf8ba31bd3d9b37d5947 (patch)
tree47f0ac38fc4f44b491495d1bd5d78a627ff644fb /emulators/xen-kernel
parent0263211fa789b2034440f0780c18fe4baef0321a (diff)
downloadports-c5fa7de8737f5252c4cedf8ba31bd3d9b37d5947.tar.gz
ports-c5fa7de8737f5252c4cedf8ba31bd3d9b37d5947.zip
Notes
Diffstat (limited to 'emulators/xen-kernel')
-rw-r--r--emulators/xen-kernel/Makefile5
-rw-r--r--emulators/xen-kernel/files/0001-libelf-fix-elf_parse_bsdsyms-call.patch36
2 files changed, 39 insertions, 2 deletions
diff --git a/emulators/xen-kernel/Makefile b/emulators/xen-kernel/Makefile
index 949064b0d708..c490fd4a88c4 100644
--- a/emulators/xen-kernel/Makefile
+++ b/emulators/xen-kernel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xen
PKGNAMESUFFIX= -kernel
PORTVERSION= 4.5.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= http://bits.xensource.com/oss-xen/release/${PORTVERSION}/
@@ -36,7 +36,8 @@ EXTRA_PATCHES= ${FILESDIR}/iommu_share_p2m_table.patch:-p2 \
${FILESDIR}/xsa127-4.x.patch:-p2 \
${FILESDIR}/xsa132.patch:-p2 \
${FILESDIR}/xsa134.patch:-p2 \
- ${FILESDIR}/xsa136.patch:-p2
+ ${FILESDIR}/xsa136.patch:-p2 \
+ ${FILESDIR}/0001-libelf-fix-elf_parse_bsdsyms-call.patch:-p2
.include <bsd.port.options.mk>
diff --git a/emulators/xen-kernel/files/0001-libelf-fix-elf_parse_bsdsyms-call.patch b/emulators/xen-kernel/files/0001-libelf-fix-elf_parse_bsdsyms-call.patch
new file mode 100644
index 000000000000..ddab05badaed
--- /dev/null
+++ b/emulators/xen-kernel/files/0001-libelf-fix-elf_parse_bsdsyms-call.patch
@@ -0,0 +1,36 @@
+From c2da83662498a5cd66512c684a0af178228f9d5a Mon Sep 17 00:00:00 2001
+From: Roger Pau Monne <roger.pau@citrix.com>
+Date: Thu, 11 Jun 2015 17:08:26 +0200
+Subject: [PATCH 1/2] libelf: fix elf_parse_bsdsyms call
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+elf_parse_bsdsyms expects the second paramater to be a physical address, not
+a virtual one.
+
+Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
+Cc: Ian Campbell <ian.campbell@citrix.com>
+Cc: Ian Jackson <ian.jackson@eu.citrix.com>
+Cc: Jan Beulich <jbeulich@suse.com>
+Cc: Tim Deegan <tim@xen.org>
+---
+ xen/common/libelf/libelf-dominfo.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/xen/common/libelf/libelf-dominfo.c b/xen/common/libelf/libelf-dominfo.c
+index 6120dd4..86403b9 100644
+--- a/xen/common/libelf/libelf-dominfo.c
++++ b/xen/common/libelf/libelf-dominfo.c
+@@ -438,7 +438,7 @@ static elf_errorstatus elf_xen_addr_calc_check(struct elf_binary *elf,
+
+ if ( parms->bsd_symtab )
+ {
+- elf_parse_bsdsyms(elf, parms->virt_kend);
++ elf_parse_bsdsyms(elf, elf->pend);
+ if ( elf->bsd_symtab_pend )
+ parms->virt_kend = elf->bsd_symtab_pend + parms->virt_offset;
+ }
+--
+1.9.5 (Apple Git-50.3)
+