aboutsummaryrefslogtreecommitdiff
path: root/emulators/xen-kernel
diff options
context:
space:
mode:
authorRoger Pau Monné <royger@FreeBSD.org>2018-01-23 16:30:48 +0000
committerRoger Pau Monné <royger@FreeBSD.org>2018-01-23 16:30:48 +0000
commit0cf5fe5c18aac09c24082203a1e0a9b361525be0 (patch)
tree3baa168d3dd5d8887ab56c025f8f59804695f900 /emulators/xen-kernel
parent989d8dbb27ef7cd5e8c260d2197a193f7dcee6af (diff)
downloadports-0cf5fe5c18aac09c24082203a1e0a9b361525be0.tar.gz
ports-0cf5fe5c18aac09c24082203a1e0a9b361525be0.zip
xen-kernel: fix build with clang 6 and apply pending XSA patches
This includes a band-aid for running 64bit PV guests without compromising the whole system. Commit the makefile diff left behind in r459786. MFH: 2018Q1 Sponsored by: Citrix Systems R&D
Notes
Notes: svn path=/head/; revision=459787
Diffstat (limited to 'emulators/xen-kernel')
-rw-r--r--emulators/xen-kernel/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/emulators/xen-kernel/Makefile b/emulators/xen-kernel/Makefile
index 68d69739a497..be25e49bf66b 100644
--- a/emulators/xen-kernel/Makefile
+++ b/emulators/xen-kernel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xen
PORTVERSION= 4.7.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
PKGNAMESUFFIX= -kernel
@@ -81,7 +81,17 @@ EXTRA_PATCHES= ${FILESDIR}/0001-xen-logdirty-prevent-preemption-if-finished.patc
${FILESDIR}/xsa242-4.9.patch:-p1 \
${FILESDIR}/xsa243-4.7.patch:-p1 \
${FILESDIR}/xsa244-4.7.patch:-p1 \
- ${FILESDIR}/xsa236-4.9.patch:-p1
+ ${FILESDIR}/xsa236-4.9.patch:-p1 \
+ ${FILESDIR}/0001-x86-compat-fix-compilation-errors-with-clang-6.patch:-p1 \
+ ${FILESDIR}/xsa246-4.7.patch:-p1 \
+ ${FILESDIR}/0001-p2m-Always-check-to-see-if-removing-a-p2m-entry-actu.patch:-p1 \
+ ${FILESDIR}/0002-p2m-Check-return-value-of-p2m_set_entry-when-decreas.patch:-p1 \
+ ${FILESDIR}/xsa248-4.8.patch:-p1 \
+ ${FILESDIR}/xsa249.patch:-p1 \
+ ${FILESDIR}/xsa250.patch:-p1 \
+ ${FILESDIR}/xsa251-4.8.patch:-p1 \
+ ${FILESDIR}/0001-x86-Meltdown-band-aid-against-malicious-64-bit-PV-gu.patch:-p1 \
+ ${FILESDIR}/0002-x86-allow-Meltdown-band-aid-to-be-disabled.patch:-p1
.include <bsd.port.options.mk>