aboutsummaryrefslogtreecommitdiff
path: root/emulators/xgngeo/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-02 03:14:36 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-02 03:14:36 +0000
commitcacf0e81a540a13639627f2f6bf5e105d98232ca (patch)
treed79e1ba69f68ebc89b228e24a143fc0a1fb6ad63 /emulators/xgngeo/Makefile
parent53629f86b029dd4f18a0a856203cba9bd27d0ec5 (diff)
downloadports-cacf0e81a540a13639627f2f6bf5e105d98232ca.tar.gz
ports-cacf0e81a540a13639627f2f6bf5e105d98232ca.zip
Notes
Diffstat (limited to 'emulators/xgngeo/Makefile')
-rw-r--r--emulators/xgngeo/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/emulators/xgngeo/Makefile b/emulators/xgngeo/Makefile
index 97fc56d9fbbb..1e58c55775ad 100644
--- a/emulators/xgngeo/Makefile
+++ b/emulators/xgngeo/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= xgngeo
-PORTVERSION= 16b
+PORTVERSION= 16
+PORTEPOCH= 1
CATEGORIES= emulators games
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME:S/xg/XG/}-${PORTVERSION:S/b/_beta/}
+DISTNAME= ${PORTNAME:S/xg/XG/}-${PORTVERSION}
DIST_SUBDIR= gngeo
MAINTAINER= acm@FreeBSD.org
@@ -25,6 +26,16 @@ USE_GETTEXT= yes
USE_PYDISTUTILS= yes
NO_BUILD= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_PSYCO= yes
+.endif
+
+.if !defined(WITHOUT_PSYCO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/data/py/configfile.py
@@ -34,4 +45,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/xgngeo-doc.pdf ${WRKSRC}/doc/xgngeo-doc.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>