aboutsummaryrefslogtreecommitdiff
path: root/emulators/xgngeo/files
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-01 10:59:41 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-01 10:59:41 +0000
commit05abfcafad41b97e180315d73f2c39d414db80e7 (patch)
tree5ad0556d7ad0e13efa5fd1c48977160d0ade2bad /emulators/xgngeo/files
parenta871cc45d840ee993d799ea468688de383013c84 (diff)
downloadports-05abfcafad41b97e180315d73f2c39d414db80e7.tar.gz
ports-05abfcafad41b97e180315d73f2c39d414db80e7.zip
Notes
Diffstat (limited to 'emulators/xgngeo/files')
-rw-r--r--emulators/xgngeo/files/patch-data-py___init__.py11
-rw-r--r--emulators/xgngeo/files/patch-data-py_configfile.py39
-rw-r--r--emulators/xgngeo/files/patch-setup.py19
-rw-r--r--emulators/xgngeo/files/patch-xgngeo.py80
4 files changed, 39 insertions, 110 deletions
diff --git a/emulators/xgngeo/files/patch-data-py___init__.py b/emulators/xgngeo/files/patch-data-py___init__.py
new file mode 100644
index 000000000000..c1d113a0d0d4
--- /dev/null
+++ b/emulators/xgngeo/files/patch-data-py___init__.py
@@ -0,0 +1,11 @@
+--- data/py/__init__.py Tue Aug 1 00:19:19 2006
++++ data/py/__init__.py Tue Aug 1 00:19:52 2006
+@@ -33,7 +33,7 @@
+ datarootpath = os.path.join(sys.prefix,'share','xgngeo')
+
+ #Internationalization.
+-gettext.install("xgngeo",os.path.join(datarootpath,"locale"))
++gettext.install("xgngeo",os.path.join(sys.prefix,"share","locale"))
+
+ class XGngeo:
+ def __init__(self):
diff --git a/emulators/xgngeo/files/patch-data-py_configfile.py b/emulators/xgngeo/files/patch-data-py_configfile.py
index ca36c82fd3f1..affdee6722d1 100644
--- a/emulators/xgngeo/files/patch-data-py_configfile.py
+++ b/emulators/xgngeo/files/patch-data-py_configfile.py
@@ -1,32 +1,11 @@
---- data/py/configfile.py Thu Jul 14 13:48:58 2005
-+++ data/py/configfile.py Fri Apr 14 01:25:46 2006
-@@ -33,7 +33,7 @@
- as the `gngeorc'."""
-
- def __init__(self):
-- self.xgngeoconfPath = "data/xgngeo.conf" #Path to XGngeo config file.
-+ self.xgngeoconfPath = os.path.join(os.getenv("HOME"),".gngeo/xgngeo.conf") #Path to XGngeo config file.
- self.gngeoDir = os.path.expanduser("~/.gngeo") #Gngeo local configuration directory.
- self.gngeorcPath = os.path.join(self.gngeoDir,"gngeorc") #Path to Gngeo config file.
-
-@@ -42,9 +42,9 @@
- and XGngeo configuration files."""
- return { #Gngeo default.
- #Path
+--- data/py/configfile.py Fri Jul 14 07:30:15 2006
++++ data/py/configfile.py Tue Aug 1 00:01:53 2006
+@@ -90,7 +90,7 @@
+ "68kclock":0,
+ "z80clock":0,
+ #Other thing section.
- "libglpath":"/usr/lib/libGL.so",
+ "libglpath":"%%X11BASE%%/lib/libGL.so",
- "rompath": os.path.join(os.getenv("HOME"),"..."),
-- "romrc":"/usr/local/share/gngeo/romrc",
-+ "romrc":"%%X11BASE%%/share/gngeo/romrc",
- #Graphic
- "blitter":"soft",
- "effect":"none",
-@@ -74,7 +74,7 @@
- "previewimages":"false",
- "previewimagedir":"data/previewimages/",
- "rominfos":"true",
-- "rominfoxml":"data/rominfos.xml",
-+ "rominfoxml":"%%DATADIR%%/rominfos.xml",
- "showavailableromsonly":"true"
- }
-
+ "sleepidle":"true",
+ "bench":"false",
+ },{ #XGngeo default.
diff --git a/emulators/xgngeo/files/patch-setup.py b/emulators/xgngeo/files/patch-setup.py
new file mode 100644
index 000000000000..5b0ed7c1187b
--- /dev/null
+++ b/emulators/xgngeo/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py Tue Aug 1 00:23:11 2006
++++ setup.py Tue Aug 1 00:23:43 2006
+@@ -48,11 +48,11 @@
+ #Plan text documentation.
+ (os.path.join("share","xgngeo","doc"),[os.path.join("doc","xgngeo-doc.txt")]),
+ #Localization files.
+- (os.path.join("share","xgngeo","locale","es","LC_MESSAGES"),[os.path.join("data","locale","es","LC_MESSAGES","xgngeo.mo")]), #Spanish
+- (os.path.join("share","xgngeo","locale","de","LC_MESSAGES"),[os.path.join("data","locale","de","LC_MESSAGES","xgngeo.mo")]), #German
+- (os.path.join("share","xgngeo","locale","fr","LC_MESSAGES"),[os.path.join("data","locale","fr","LC_MESSAGES","xgngeo.mo")]), #French
+- (os.path.join("share","xgngeo","locale","pl","LC_MESSAGES"),[os.path.join("data","locale","pl","LC_MESSAGES","xgngeo.mo")]), #Polish
+- (os.path.join("share","xgngeo","locale","pt_BR","LC_MESSAGES"),[os.path.join("data","locale","pt_BR","LC_MESSAGES","xgngeo.mo")]) #Portuguese of Brazil
++ (os.path.join("share","locale","es","LC_MESSAGES"),[os.path.join("data","locale","es","LC_MESSAGES","xgngeo.mo")]), #Spanish
++ (os.path.join("share","locale","de","LC_MESSAGES"),[os.path.join("data","locale","de","LC_MESSAGES","xgngeo.mo")]), #German
++ (os.path.join("share","locale","fr","LC_MESSAGES"),[os.path.join("data","locale","fr","LC_MESSAGES","xgngeo.mo")]), #French
++ (os.path.join("share","locale","pl","LC_MESSAGES"),[os.path.join("data","locale","pl","LC_MESSAGES","xgngeo.mo")]), #Polish
++ (os.path.join("share","locale","pt_BR","LC_MESSAGES"),[os.path.join("data","locale","pt_BR","LC_MESSAGES","xgngeo.mo")]) #Portuguese of Brazil
+ ],
+ scripts = [os.path.join("data","script","xgngeo_startup.py")] #Startup script.
+ )
diff --git a/emulators/xgngeo/files/patch-xgngeo.py b/emulators/xgngeo/files/patch-xgngeo.py
deleted file mode 100644
index 2b8acaa4c570..000000000000
--- a/emulators/xgngeo/files/patch-xgngeo.py
+++ /dev/null
@@ -1,80 +0,0 @@
---- xgngeo.py Thu Jul 14 13:48:58 2005
-+++ /home/acardenas/xgngeo.py Thu Mar 2 21:39:00 2006
-@@ -28,14 +28,14 @@
- os.chdir(os.path.abspath(syspath[0]))
-
- #Add `data/py/' to PATH, then import internal modules.
--syspath.append("data/py/")
-+syspath.append("%%DATADIR%%/py/")
- import command, configfile, history, rominfos, romrcfile
-
- VERSION = 15
- gngeoDir = os.path.expanduser("~/.gngeo")
-
- #Internationalization.
--gettext.install("xgngeo","data/lang")
-+gettext.install("xgngeo","%%X11BASE%%/share/locale")
-
- class XGngeo:
- def checkError(self):
-@@ -591,7 +591,7 @@
- frame.add(box)
-
- logo = gtk.Image()
-- logo.set_from_file("data/img/chprod.png")
-+ logo.set_from_file("%%DATADIR%%/img/chprod.png")
- box.pack_start(logo,False)
-
- box2 = gtk.VBox(spacing=4)
-@@ -1087,7 +1087,7 @@
-
- #Generate key's image
- image = gtk.Image()
-- image.set_from_file("data/img/key_%s.png" % key_list[i])
-+ image.set_from_file("%%DATADIR%%/img/key_%s.png" % key_list[i])
-
- box2 = gtk.HBox() #A box...
- box2.pack_start(p1keywidgets[i]) #with P1 key...
-@@ -1131,21 +1131,21 @@
- if temp_param["country"]=="japan": self.configwidgets['country_japan'].set_active(1)
- table.attach(self.configwidgets['country_japan'],0,1,0,1)
- image = gtk.Image()
-- image.set_from_file("data/img/japan.png")
-+ image.set_from_file("%%DATADIR%%/img/japan.png")
- table.attach(image,0,1,1,2)
-
- self.configwidgets['country_usa'] = gtk.RadioButton(self.configwidgets['country_japan'],_("USA"))
- if temp_param["country"]=="usa": self.configwidgets['country_usa'].set_active(1)
- table.attach(self.configwidgets['country_usa'],1,2,0,1)
- image = gtk.Image()
-- image.set_from_file("data/img/usa.png")
-+ image.set_from_file("%%DATADIR%%/img/usa.png")
- table.attach(image,1,2,1,2)
-
- radio = gtk.RadioButton(self.configwidgets['country_japan'],_("Europe"))
- if temp_param["country"]=="europe": radio.set_active(1)
- table.attach(radio,2,3,0,1)
- image = gtk.Image()
-- image.set_from_file("data/img/europe.png")
-+ image.set_from_file("%%DATADIR%%/img/europe.png")
- table.attach(image,2,3,1,2)
- frame2.add(table)
- box.pack_start(frame2)
-@@ -1408,7 +1408,7 @@
- self.context_id = self.statusbar.get_context_id("Info")
-
- self.window = gtk.Window(gtk.WINDOW_TOPLEVEL)
-- gtk.window_set_default_icon_from_file("data/img/icon.png")
-+ gtk.window_set_default_icon_from_file("%%DATADIR%%/img/icon.png")
-
- def main(self):
- #Window attributes.
-@@ -1536,7 +1536,7 @@
- container = gtk.EventBox()
- container.modify_bg(gtk.STATE_NORMAL,gtk.gdk.color_parse("white"))
- logo = gtk.Image()
-- logo.set_from_file("data/img/xgngeo.png")
-+ logo.set_from_file("%%DATADIR%%/img/xgngeo.png")
- logo.set_padding(25,2)
- container.add(logo)
- box.pack_start(container)