aboutsummaryrefslogtreecommitdiff
path: root/emulators/xgngeo
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-11-01 04:02:56 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-11-01 04:02:56 +0000
commiteff49a089b4021d776005ccf0433bd30c624bb40 (patch)
tree6ea17bfcac0c76e957958fa2c6533f7e2c7b1969 /emulators/xgngeo
parent516f954da063bf3b1e9983f677431e07ba297252 (diff)
downloadports-eff49a089b4021d776005ccf0433bd30c624bb40.tar.gz
ports-eff49a089b4021d776005ccf0433bd30c624bb40.zip
Notes
Diffstat (limited to 'emulators/xgngeo')
-rw-r--r--emulators/xgngeo/Makefile4
-rw-r--r--emulators/xgngeo/files/patch-data-py_command.py23
2 files changed, 27 insertions, 0 deletions
diff --git a/emulators/xgngeo/Makefile b/emulators/xgngeo/Makefile
index 1e58c55775ad..2a577cb69390 100644
--- a/emulators/xgngeo/Makefile
+++ b/emulators/xgngeo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xgngeo
PORTVERSION= 16
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators games
MASTER_SITES= ${MASTER_SITE_BERLIOS}
@@ -38,6 +39,9 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
post-patch:
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/data/py/configfile.py
+ @${REINPLACE_CMD} -e 's|gtk.threads_init|gtk.gdk.threads_init|g' -e \
+ 's|gtk.threads_enter|gtk.gdk.threads_enter|g' -e \
+ 's|gtk.threads_leave|gtk.gdk.threads_leave|g' ${WRKSRC}/data/py/__init__.py
post-install:
.if !defined(NOPORTDOCS)
diff --git a/emulators/xgngeo/files/patch-data-py_command.py b/emulators/xgngeo/files/patch-data-py_command.py
new file mode 100644
index 000000000000..68276ab10237
--- /dev/null
+++ b/emulators/xgngeo/files/patch-data-py_command.py
@@ -0,0 +1,23 @@
+--- data/py/command.py Tue Oct 17 22:10:04 2006
++++ data/py/command.py Tue Oct 17 22:10:28 2006
+@@ -26,6 +26,8 @@
+ # $Source: /cvsroot/xgngeo/xgngeo/data/py/command.py,v $
+ __date__ = "$Date: 2006/07/23 15:02:17 $"
+
++import gtk
++
+ from threading import Thread
+ from gtk import threads_enter, threads_leave
+ from os import popen
+@@ -37,9 +39,9 @@
+ self.output = ""
+
+ def run(self):
+- threads_enter()
++ gtk.gdk.threads_enter()
+ pipe = popen(self.command,"r")
+- threads_leave()
++ gtk.gdk.threads_leave()
+ self.output = pipe.read()
+
+ def get_output(self):