aboutsummaryrefslogtreecommitdiff
path: root/emulators/xhomer/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-07-16 20:02:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-07-16 20:02:27 +0000
commitdbcf5348b9c682d9a1c217e142c50e92a788fadc (patch)
tree4278611a8ce7053f1cf6d3502dd6c85d0f05e600 /emulators/xhomer/Makefile
parent58deda86b0685df8fa7037ee9f1c1eddfc8be55a (diff)
downloadports-dbcf5348b9c682d9a1c217e142c50e92a788fadc.tar.gz
ports-dbcf5348b9c682d9a1c217e142c50e92a788fadc.zip
Notes
Diffstat (limited to 'emulators/xhomer/Makefile')
-rw-r--r--emulators/xhomer/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/emulators/xhomer/Makefile b/emulators/xhomer/Makefile
new file mode 100644
index 000000000000..25506a8da316
--- /dev/null
+++ b/emulators/xhomer/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: xhomer
+# Date created: 24 May 2006
+# Whom: trasz
+#
+# $FreeBSD$
+#
+
+PORTNAME= xhomer
+DISTVERSION= 12-14-03
+CATEGORIES= emulators
+MASTER_SITES= http://xhomer.isani.org/xhomer/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Emulator for the DEC Pro 350 computer
+
+USE_GMAKE= yes
+USE_XLIB= yes
+ALL_TARGET= clean xhomer
+INSTALL_TARGET=
+CFLAGS+= -Wall -ffloat-store
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PLIST_FILES= bin/xhomer %%EXAMPLESDIR%%/xhomer.cfg
+PLIST_DIRS= %%EXAMPLESDIR%%
+PORTDOCS= README LICENSE SIMH
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/xhomer ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xhomer.cfg ${EXAMPLESDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>