aboutsummaryrefslogtreecommitdiff
path: root/emulators/xhomer
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-07-16 20:02:27 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-07-16 20:02:27 +0000
commitdbcf5348b9c682d9a1c217e142c50e92a788fadc (patch)
tree4278611a8ce7053f1cf6d3502dd6c85d0f05e600 /emulators/xhomer
parent58deda86b0685df8fa7037ee9f1c1eddfc8be55a (diff)
downloadports-dbcf5348b9c682d9a1c217e142c50e92a788fadc.tar.gz
ports-dbcf5348b9c682d9a1c217e142c50e92a788fadc.zip
Notes
Diffstat (limited to 'emulators/xhomer')
-rw-r--r--emulators/xhomer/Makefile39
-rw-r--r--emulators/xhomer/distinfo3
-rw-r--r--emulators/xhomer/files/patch-Makefile34
-rw-r--r--emulators/xhomer/files/pkg-message.in7
-rw-r--r--emulators/xhomer/pkg-descr6
5 files changed, 89 insertions, 0 deletions
diff --git a/emulators/xhomer/Makefile b/emulators/xhomer/Makefile
new file mode 100644
index 000000000000..25506a8da316
--- /dev/null
+++ b/emulators/xhomer/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: xhomer
+# Date created: 24 May 2006
+# Whom: trasz
+#
+# $FreeBSD$
+#
+
+PORTNAME= xhomer
+DISTVERSION= 12-14-03
+CATEGORIES= emulators
+MASTER_SITES= http://xhomer.isani.org/xhomer/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Emulator for the DEC Pro 350 computer
+
+USE_GMAKE= yes
+USE_XLIB= yes
+ALL_TARGET= clean xhomer
+INSTALL_TARGET=
+CFLAGS+= -Wall -ffloat-store
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PLIST_FILES= bin/xhomer %%EXAMPLESDIR%%/xhomer.cfg
+PLIST_DIRS= %%EXAMPLESDIR%%
+PORTDOCS= README LICENSE SIMH
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/xhomer ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xhomer.cfg ${EXAMPLESDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/emulators/xhomer/distinfo b/emulators/xhomer/distinfo
new file mode 100644
index 000000000000..8da6edb5b682
--- /dev/null
+++ b/emulators/xhomer/distinfo
@@ -0,0 +1,3 @@
+MD5 (xhomer-12-14-03.tgz) = 7eab258f5a130be9950c2032a9e10946
+SHA256 (xhomer-12-14-03.tgz) = ed043165ef650997b79aadcf675bdeeddce7bcaae8572222d2bfa09c95f277fc
+SIZE (xhomer-12-14-03.tgz) = 312166
diff --git a/emulators/xhomer/files/patch-Makefile b/emulators/xhomer/files/patch-Makefile
new file mode 100644
index 000000000000..69c264b6d075
--- /dev/null
+++ b/emulators/xhomer/files/patch-Makefile
@@ -0,0 +1,34 @@
+--- Makefile.orig Tue Dec 9 18:36:07 2003
++++ Makefile Wed May 24 19:59:13 2006
+@@ -115,17 +115,17 @@
+ # C-Compiler configuration
+
+ # All the rest of the flags in this section assume gcc
+-CC=gcc -Wall
++#CC=gcc -Wall
+ # -Wchar-subscripts -W -Wshadow -Wconversion
+ # -Wtraditional -Wstrict-prototypes
+
+ # This prevents "undesirable excess precision" on some machines, says gcc
+-CC += -ffloat-store
++#CC += -ffloat-store
+
+ # The 1st choice runs about 15% slower than the 2nd (-O3 -fomit-frame-pointer).
+ # but it (re)compiles faster and unlike the second choice, it is debuggable.
+ # CC += -g -O -fno-inline
+-CC += -O3 -Winline -fomit-frame-pointer
++#CC += -O3 -Winline -fomit-frame-pointer
+
+ # Some older gcc's need this on i386 to work around a bug. As long as
+ # omit-frame-pointer is also set, it doesn't seem to hurt performance, so
+@@ -184,8 +184,8 @@
+
+ # Try this as the default place for X11 stuff and ncurses
+
+- CCINCS = -I$(X11DIR)/include -I/usr/X11/include -I$(NCURSESINC)
+- CCLIBS = -L$(X11DIR)/lib -L/usr/X11/lib -L$(NCURSESLIB)
++ CCINCS = -I$(X11DIR)/include
++ CCLIBS = -L$(X11DIR)/lib -L$(NCURSESLIB)
+
+ # But some vendors put things in non-standard places
+
diff --git a/emulators/xhomer/files/pkg-message.in b/emulators/xhomer/files/pkg-message.in
new file mode 100644
index 000000000000..1894bde3061c
--- /dev/null
+++ b/emulators/xhomer/files/pkg-message.in
@@ -0,0 +1,7 @@
+*****************************************************************************
+Please see %%DOCSDIR%%/README for instructions. Copy
+the example config file from %%PREFIX%%/share/examples/xhomer/xhomer.cfg
+to your home directory as '.xhomerrc' and set 'rd_dir' line to point
+to the directory containing disk images downloaded from
+http://xhomer.isani.org/xhomer/.
+*****************************************************************************
diff --git a/emulators/xhomer/pkg-descr b/emulators/xhomer/pkg-descr
new file mode 100644
index 000000000000..14eae1ebb61a
--- /dev/null
+++ b/emulators/xhomer/pkg-descr
@@ -0,0 +1,6 @@
+Xhomer is a machine emulator for the Digital Equipment Corporation
+(DEC) Pro 350 computer, a PDP-11-based machine that was sold in the
+early to mid-'80's. Xhomer is based on the PDP-11 CPU core from
+the SIMH simulator, and is written entirely in C.
+
+WWW: http://xhomer.isani.org/