aboutsummaryrefslogtreecommitdiff
path: root/emulators/xmame/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-09-04 20:22:36 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-09-04 20:22:36 +0000
commit44dfea1a175e451649471e1757eb14c81882368d (patch)
treeacd0fa10438baf5dc8beb89fea5c886276e0e451 /emulators/xmame/Makefile
parentc799c513f4daee92e0b6adf407bd1b1350537798 (diff)
Notes
Diffstat (limited to 'emulators/xmame/Makefile')
-rw-r--r--emulators/xmame/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/emulators/xmame/Makefile b/emulators/xmame/Makefile
index 4306b87e2484..b83f2f596177 100644
--- a/emulators/xmame/Makefile
+++ b/emulators/xmame/Makefile
@@ -1,17 +1,19 @@
# New ports collection makefile for: xmame
-# Version required: 0.33b6.1
-# Date created: 8 Feb 1998
+# Version required: 0.36b3.1
+# Date created: 4 Sep 1999
# Whom: Donald Burr <dburr@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= xmame-0.33b6.1
+DISTNAME= xmame-0.36b3.1
CATEGORIES= emulators
-MASTER_SITES= ftp://drake.dit.upm.es/xmame/ftpsite/
+MASTER_SITES= http://xmame.retrogames.com/download/ \
+ ftp://ftp.kaupp.cx/pub/xmame/ \
+ ftp://ftp.bingo-ev.de/pub/software/emulator/
EXTRACT_SUFX= .tgz
-MAINTAINER= dburr@FreeBSD.org
+MAINTAINER= dburr@FreeBSD.org
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
@@ -21,14 +23,10 @@ MAKEFILE= makefile.unix
MAN6= xmame.6
post-install:
-.ifdef NOPORTDOCS
- @${ECHO_MSG} "==> Extra documentation WILL NOT be installed."
-.else
- @${ECHO_MSG} "==> Installing extra documentation..."
- ${MKDIR} ${PREFIX}/lib/mame
- for DOC in CHEAT.DOC Changes MailList.notes README.unix mamelist.txt readme.dos whatsnew.txt; do ${INSTALL} -c -o bin -g bin -m 444 ${WRKSRC}/doc/$${DOC} ${PREFIX}/lib/mame/$${DOC}; done
-.endif
- (cd ${PREFIX}/lib/mame; sh ${FILESDIR}/dos2unx CHEAT.DOC Changes MailList.notes README.unix cheat.dat mamelist.txt readme.dos whatsnew.txt)
- @${CAT} ${PKGDIR}/MESSAGE
+ ${MKDIR} ${PREFIX}/lib/xmame ${PREFIX}/lib/xmame/doc ${PREFIX}/lib/xmame/hi ${PREFIX}/lib/xmame/roms
+ ${CHMOD} 777 ${PREFIX}/lib/xmame/hi
+ for file in cheat.dat history.dat README.unix gamelist.txt; do ${INSTALL} -C -o root -g wheel -m 444 ${WRKSRC}/doc/$${file} ${PREFIX}/lib/xmame/$${file}; done
+ ${INSTALL} -C -o root -g wheel -m 644 ${WRKSRC}/doc/xmamerc.dist ${PREFIX}/lib/xmame/xmamerc
+ for file in Changes LEEME.unix MailList.notes README.fx README.xgl TODO cheat.doc credits.unix liesmich.unix multiplayer-readme.txt readme.dos whatsnew.txt; do ${INSTALL} -C -o root -g wheel -m 444 ${WRKSRC}/doc/$${file} ${PREFIX}/lib/xmame/doc/$${file}; done
.include <bsd.port.mk>