aboutsummaryrefslogtreecommitdiff
path: root/emulators/xmess
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-10-31 22:50:26 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-10-31 22:50:26 +0000
commit93ed9b565bb69f111bce68375b4d11dd8f0104d4 (patch)
tree5dce713c3724f62452096af9a8a27351a18e4b7d /emulators/xmess
parent7ea12e59adce9f7d57d2c34d4f531eb6758de357 (diff)
downloadports-93ed9b565bb69f111bce68375b4d11dd8f0104d4.tar.gz
ports-93ed9b565bb69f111bce68375b4d11dd8f0104d4.zip
Notes
Diffstat (limited to 'emulators/xmess')
-rw-r--r--emulators/xmess/Makefile2
-rw-r--r--emulators/xmess/files/patch-makefile.unix15
-rw-r--r--emulators/xmess/files/patch-src-unix::unix.mak28
-rw-r--r--emulators/xmess/files/patch-src::unix::dsp-drivers::oss.c (renamed from emulators/xmess/files/patch-src-unix::sysdep::dsp-drivers::oss.c)4
-rw-r--r--emulators/xmess/files/patch-src::unix::joystick-drivers::joy_usb.c46
-rw-r--r--emulators/xmess/files/patch-src::unix::sysdep::mixer-drivers::oss.c (renamed from emulators/xmess/files/patch-src-unix::sysdep::mixer-drivers::oss.c)4
-rw-r--r--emulators/xmess/files/patch-src::unix::unix.mak56
-rw-r--r--emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c13
8 files changed, 135 insertions, 33 deletions
diff --git a/emulators/xmess/Makefile b/emulators/xmess/Makefile
index e0b5562be5ea..b2fca64493f5 100644
--- a/emulators/xmess/Makefile
+++ b/emulators/xmess/Makefile
@@ -11,7 +11,7 @@ PORTVERSION= 0.56.2
MAINTAINER= stijn@win.tue.nl
MASTERDIR= ${.CURDIR}/../xmame
-PATCHDIR= $(.CURDIR)/files
+PATCHDIR= ${.CURDIR}/files
COMMENT= ${.CURDIR}/pkg-comment
DESCR= ${.CURDIR}/pkg-descr
diff --git a/emulators/xmess/files/patch-makefile.unix b/emulators/xmess/files/patch-makefile.unix
new file mode 100644
index 000000000000..9e5497739efb
--- /dev/null
+++ b/emulators/xmess/files/patch-makefile.unix
@@ -0,0 +1,15 @@
+--- makefile.unix.orig Fri May 3 02:53:55 2002
++++ makefile.unix Thu Oct 31 12:40:33 2002
+@@ -363,6 +363,12 @@
+ # XINPUT_DEVICES = 1
+
+ ##############################################################################
++# *** SDL options, only needed for SDL as display method
++##############################################################################
++# *** The name of your sdl-config executable
++SDL_CONFIG = sdl-config
++
++##############################################################################
+ # *** OpenGL info -- configure if you are using the xgl display option
+ ##############################################################################
+ GLLIBS= -ldl
diff --git a/emulators/xmess/files/patch-src-unix::unix.mak b/emulators/xmess/files/patch-src-unix::unix.mak
deleted file mode 100644
index 823182c58112..000000000000
--- a/emulators/xmess/files/patch-src-unix::unix.mak
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/unix/unix.mak.orig Sun Jul 28 18:47:11 2002
-+++ src/unix/unix.mak Sun Jul 28 18:54:26 2002
-@@ -45,20 +45,20 @@
-
- # svga and ggi also use $(X11LIB) since that's where zlib often is
- LIBS.x11 = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext
--LIBS.svgalib = $(X11LIB) -lvga -lvgagl
-+LIBS.svgalib = $(LOCALBASE)/lib -lvga -lvgagl
- LIBS.ggi = $(X11LIB) -lggi
--LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -ljpeg
-+LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -L$(LOCALBASE)/lib -ljpeg
- LIBS.xfx = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext -lglide2x
- LIBS.svgafx = $(X11LIB) -lvga -lvgagl -lglide2x
- LIBS.openstep = -framework AppKit
--LIBS.SDL = `sdl-config --libs`
-+LIBS.SDL = `$(SDL_CONFIG) --libs`
- LIBS.photon2 = -L/usr/lib -lph -lphrender
-
- CFLAGS.x11 = $(X11INC) $(JOY_X11_CFLAGS)
--CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS)
-+CFLAGS.xgl = -DGLU_VERSION_1_2 $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS) -I$(LOCALBASE)/include $(PTHREAD_CFLAGS)
- CFLAGS.xfx = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/include/glide
- CFLAGS.svgafx = -I/usr/include/glide
--CFLAGS.SDL = -D_REENTRANT
-+CFLAGS.SDL = $(X11INC) `$(SDL_CONFIG) --cflags`
- CFLAGS.photon2 =
-
- INST.x11 = doinstall
diff --git a/emulators/xmess/files/patch-src-unix::sysdep::dsp-drivers::oss.c b/emulators/xmess/files/patch-src::unix::dsp-drivers::oss.c
index 70c42b9da83e..67a8e0fccb8c 100644
--- a/emulators/xmess/files/patch-src-unix::sysdep::dsp-drivers::oss.c
+++ b/emulators/xmess/files/patch-src::unix::dsp-drivers::oss.c
@@ -1,5 +1,5 @@
---- ./src/unix/sysdep/dsp-drivers/oss.c.orig Sun Sep 8 01:12:54 2002
-+++ ./src/unix/sysdep/dsp-drivers/oss.c Sun Sep 8 01:13:03 2002
+--- src/unix/sysdep/dsp-drivers/oss.c.orig Fri May 3 02:53:54 2002
++++ src/unix/sysdep/dsp-drivers/oss.c Thu Oct 31 12:46:35 2002
@@ -29,9 +29,7 @@
#include <sys/types.h>
#include <sys/stat.h>
diff --git a/emulators/xmess/files/patch-src::unix::joystick-drivers::joy_usb.c b/emulators/xmess/files/patch-src::unix::joystick-drivers::joy_usb.c
new file mode 100644
index 000000000000..5e6c05e1c6bf
--- /dev/null
+++ b/emulators/xmess/files/patch-src::unix::joystick-drivers::joy_usb.c
@@ -0,0 +1,46 @@
+--- src/unix/joystick-drivers/joy_usb.c.orig Sat Nov 3 02:22:56 2001
++++ src/unix/joystick-drivers/joy_usb.c Thu Oct 31 15:27:02 2002
+@@ -23,8 +23,12 @@
+ #if defined(__ARCH_netbsd)
+ #include <usb.h>
+ #elif defined(__ARCH_freebsd)
++#ifdef HAVE_USBHID_H
++#include <libusbhid.h>
++#else
+ #include <libusb.h>
+ #endif
++#endif
+ #include <dev/usb/usb.h>
+ #include <dev/usb/usbhid.h>
+
+@@ -82,7 +86,22 @@
+
+ priv_joy_data[i].hids = NULL;
+
++#if defined(__ARCH_freebsd) && __FreeBSD_version > 500000
++ if (ioctl(joy_data[i].fd, USB_GET_REPORT_ID, &report_id) < 0)
++ {
++ fprintf(stderr_file, "error: /dev/uhid%d: %s", i, strerror(errno));
++ return FALSE;
++ }
++#endif
++
++#if defined(__ARCH_freebsd) && defined(HAVE_USBHID_H)
++ size = hid_report_size(rd, hid_input, report_id);
++ priv_joy_data[i].offset = 0;
++#else
+ size = hid_report_size(rd, hid_input, &report_id);
++ priv_joy_data[i].offset = (report_id != 0);
++#endif
++
+ if ((priv_joy_data[i].data_buf = malloc(size)) == NULL)
+ {
+ fprintf(stderr_file, "error: couldn't malloc %d bytes\n", size);
+@@ -90,7 +109,6 @@
+ return FALSE;
+ }
+ priv_joy_data[i].dlen = size;
+- priv_joy_data[i].offset = (report_id != 0);
+
+ is_joystick = 0;
+ for (d = hid_start_parse(rd, 1 << hid_input); hid_get_item(d, &h); )
diff --git a/emulators/xmess/files/patch-src-unix::sysdep::mixer-drivers::oss.c b/emulators/xmess/files/patch-src::unix::sysdep::mixer-drivers::oss.c
index e414078ed831..0b85c3d945ba 100644
--- a/emulators/xmess/files/patch-src-unix::sysdep::mixer-drivers::oss.c
+++ b/emulators/xmess/files/patch-src::unix::sysdep::mixer-drivers::oss.c
@@ -1,5 +1,5 @@
---- ./src/unix/sysdep/mixer-drivers/oss.c.orig Sun Sep 8 01:13:30 2002
-+++ ./src/unix/sysdep/mixer-drivers/oss.c Sun Sep 8 01:13:35 2002
+--- src/unix/sysdep/mixer-drivers/oss.c.orig Fri May 3 02:53:54 2002
++++ src/unix/sysdep/mixer-drivers/oss.c Thu Oct 31 12:46:55 2002
@@ -28,9 +28,7 @@
#include <sys/types.h>
#include <sys/stat.h>
diff --git a/emulators/xmess/files/patch-src::unix::unix.mak b/emulators/xmess/files/patch-src::unix::unix.mak
new file mode 100644
index 000000000000..b124af965acd
--- /dev/null
+++ b/emulators/xmess/files/patch-src::unix::unix.mak
@@ -0,0 +1,56 @@
+--- src/unix/unix.mak.orig Mon Dec 31 09:19:03 2001
++++ src/unix/unix.mak Thu Oct 31 15:25:37 2002
+@@ -51,14 +51,14 @@
+ LIBS.xfx = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext -lglide2x
+ LIBS.svgafx = $(X11LIB) -lvga -lvgagl -lglide2x
+ LIBS.openstep = -framework AppKit
+-LIBS.SDL = `sdl-config --libs`
++LIBS.SDL = $(X11LIB) `$(SDL_CONFIG) --libs`
+ LIBS.photon2 = -L/usr/lib -lph -lphrender
+
+ CFLAGS.x11 = $(X11INC) $(JOY_X11_CFLAGS)
+ CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS)
+ CFLAGS.xfx = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/include/glide
+ CFLAGS.svgafx = -I/usr/include/glide
+-CFLAGS.SDL = -D_REENTRANT
++CFLAGS.SDL = $(X11INC) `$(SDL_CONFIG) --cflags` -D_REENTRANT
+ CFLAGS.photon2 =
+
+ INST.x11 = doinstall
+@@ -210,8 +210,17 @@
+ endif
+ ifdef JOY_USB
+ CONFIG += -DUSB_JOYSTICK
++ifeq ($(ARCH), freebsd)
++ifeq ($(shell test -f /usr/include/libusbhid.h && echo have_usbhid), have_usbhid)
++CONFIG += -DHAVE_USBHID_H
++MY_LIBS += -lusbhid
++else
+ MY_LIBS += -lusb
+ endif
++else
++MY_LIBS += -lusb
++endif
++endif
+
+ ifdef EFENCE
+ MY_LIBS += -lefence
+@@ -340,7 +349,7 @@
+
+ doc/x$(TARGET)rc.dist: all src/unix/xmamerc-keybinding-notes.txt
+ ./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -showconfig | \
+- grep -v loadconfig > doc/x$(TARGET)rc.dist
++ grep -v loadconfig | tr "\033" \# > doc/x$(TARGET)rc.dist
+ cat src/unix/xmamerc-keybinding-notes.txt >> doc/x$(TARGET)rc.dist
+
+ doc/gamelist.$(TARGET): all
+@@ -349,7 +358,8 @@
+
+ doc/x$(TARGET).6: all src/unix/xmame.6-1 src/unix/xmame.6-3
+ cat src/unix/xmame.6-1 > doc/x$(TARGET).6
+- ./x$(TARGET).$(DISPLAY_METHOD) -manhelp >> doc/x$(TARGET).6
++ ./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -manhelp | \
++ tr "\033" \# >> doc/x$(TARGET).6
+ cat src/unix/xmame.6-3 >> doc/x$(TARGET).6
+
+ install: $(INST.$(DISPLAY_METHOD)) install-man
diff --git a/emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c b/emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c
new file mode 100644
index 000000000000..0095664f3723
--- /dev/null
+++ b/emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c
@@ -0,0 +1,13 @@
+--- src/unix/video-drivers/svgainput.c.orig Fri May 3 02:53:54 2002
++++ src/unix/video-drivers/svgainput.c Thu Oct 31 12:46:04 2002
+@@ -12,6 +12,10 @@
+ #include "devices.h"
+ #include "keyboard.h"
+
++#if defined(__ARCH_freebsd)
++#define SIGUNUSED SIGUSR2
++#endif
++
+ static int console_fd = -1;
+ static int mouse_fd = -1;
+ static int leds = 0;