aboutsummaryrefslogtreecommitdiff
path: root/emulators/xmess
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 19:56:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-12 19:56:09 +0000
commit2b75b207cdf816af1b67fcb248362667ce3815a7 (patch)
treecaf129c37edf54303c22275473fdda8fc433fe26 /emulators/xmess
parent936f776e88b291202e59f33368b15b8bda3ef047 (diff)
downloadports-2b75b207cdf816af1b67fcb248362667ce3815a7.tar.gz
ports-2b75b207cdf816af1b67fcb248362667ce3815a7.zip
Notes
Diffstat (limited to 'emulators/xmess')
-rw-r--r--emulators/xmess/Makefile1
-rw-r--r--emulators/xmess/files/patch-src::unix::unix.mak47
-rw-r--r--emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c13
3 files changed, 61 insertions, 0 deletions
diff --git a/emulators/xmess/Makefile b/emulators/xmess/Makefile
index 80f6a2a7d91f..92c450366f4b 100644
--- a/emulators/xmess/Makefile
+++ b/emulators/xmess/Makefile
@@ -11,6 +11,7 @@ PORTVERSION= 0.37b15.2
MAINTAINER= stijn@win.tue.nl
MASTERDIR= ${.CURDIR}/../xmame
+PATCHDIR= $(.CURDIR)/files
COMMENT= ${.CURDIR}/pkg-comment
DESCR= ${.CURDIR}/pkg-descr
diff --git a/emulators/xmess/files/patch-src::unix::unix.mak b/emulators/xmess/files/patch-src::unix::unix.mak
new file mode 100644
index 000000000000..870ca9ddff85
--- /dev/null
+++ b/emulators/xmess/files/patch-src::unix::unix.mak
@@ -0,0 +1,47 @@
+--- src/unix/unix.mak.orig Fri Aug 10 07:36:22 2001
++++ src/unix/unix.mak Wed Dec 12 11:02:58 2001
+@@ -44,20 +44,20 @@
+
+ # svga and ggi also use $(X11LIB) since that's where zlib often is
+ LIBS.x11 = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext
+-LIBS.svgalib = $(X11LIB) -lvga -lvgagl
++LIBS.svgalib = -L$(LOCALBASE)/lib -lvga -lvgagl
+ LIBS.ggi = $(X11LIB) -lggi
+-LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -ljpeg
++LIBS.xgl = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext $(GLLIBS) -L$(LOCALBASE)/lib -ljpeg
+ LIBS.xfx = $(X11LIB) $(JOY_X11_LIBS) -lX11 -lXext -lglide2x
+ LIBS.svgafx = $(X11LIB) -lvga -lvgagl -lglide2x
+ LIBS.openstep = -framework AppKit
+-LIBS.SDL = -ldl -lSDL -lpthread -D_REENTRANT
++LIBS.SDL = `$(SDL_CONFIG) --libs`
+ LIBS.photon2 = -L/usr/lib -lph -lphrender
+
+ CFLAGS.x11 = $(X11INC) $(JOY_X11_CFLAGS)
+-CFLAGS.xgl = $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS)
++CFLAGS.xgl = -DGLU_VERSION_1_2 $(X11INC) $(JOY_X11_CFLAGS) $(GLCFLAGS) -I$(LOCALBASE)/include $(PTHREAD_CFLAGS)
+ CFLAGS.xfx = $(X11INC) $(JOY_X11_CFLAGS) -I/usr/include/glide
+ CFLAGS.svgafx = -I/usr/include/glide
+-CFLAGS.SDL = -D_REENTRANT
++CFLAGS.SDL = `$(SDL_CONFIG) --cflags`
+ CFLAGS.photon2 =
+
+ INST.x11 = doinstall
+@@ -332,7 +332,7 @@
+
+ doc/x$(TARGET)rc.dist: all src/unix/xmamerc-keybinding-notes.txt
+ ./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -showconfig | \
+- grep -v loadconfig > doc/x$(TARGET)rc.dist
++ grep -v loadconfig | tr "\033" \# > doc/x$(TARGET)rc.dist
+ cat src/unix/xmamerc-keybinding-notes.txt >> doc/x$(TARGET)rc.dist
+
+ doc/gamelist.$(TARGET): all
+@@ -341,7 +341,8 @@
+
+ doc/x$(TARGET).6: all src/unix/xmame.6-1 src/unix/xmame.6-3
+ cat src/unix/xmame.6-1 > doc/x$(TARGET).6
+- ./x$(TARGET).$(DISPLAY_METHOD) -manhelp >> doc/x$(TARGET).6
++ ./x$(TARGET).$(DISPLAY_METHOD) -noloadconfig -manhelp | \
++ tr "\033" \# >> doc/x$(TARGET).6
+ cat src/unix/xmame.6-3 >> doc/x$(TARGET).6
+
+ install: $(INST.$(DISPLAY_METHOD)) install-man
diff --git a/emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c b/emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c
new file mode 100644
index 000000000000..b0462f7c8942
--- /dev/null
+++ b/emulators/xmess/files/patch-src::unix::video-drivers::svgainput.c
@@ -0,0 +1,13 @@
+--- src/unix/video-drivers/svgainput.c.orig Tue Oct 16 11:06:30 2001
++++ src/unix/video-drivers/svgainput.c Tue Oct 16 11:05:37 2001
+@@ -12,6 +12,10 @@
+ #include "devices.h"
+ #include "keyboard.h"
+
++#ifdef __FreeBSD__
++#define SIGUNUSED SIGUSR2
++#endif
++
+ static int console_fd = -1;
+ static int mouse_fd = -1;
+ static int leds = 0;