aboutsummaryrefslogtreecommitdiff
path: root/emulators/xsystem35/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2004-08-16 02:43:17 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2004-08-16 02:43:17 +0000
commit7bde97722a721c4609c220fa0c001da656caa245 (patch)
tree9f3dc463f7f8fc5062e173eea26bf44f4fb0d1e5 /emulators/xsystem35/Makefile
parentc1a0f8ede9b1500fbfeeddd49e14619623f520ad (diff)
o add missing jpeg dependency, broken configure script did not detect it.
o use custom DOCSDIR.
Notes
Notes: svn path=/head/; revision=116341
Diffstat (limited to 'emulators/xsystem35/Makefile')
-rw-r--r--emulators/xsystem35/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index f8e2e4709768..c3af8ade91e2 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://8ne.sakura.ne.jp:20008/chika/unitbase/xsys35/down/
MAINTAINER= sf@FreeBSD.org
COMMENT= AliceSoft System 3.5/3.6/3.8/3.9 on X Window System
-LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
USE_AUTOCONF_VER= 259
USE_LIBTOOL_VER= 15
@@ -25,6 +26,7 @@ USE_REINPLACE= yes
PKGMESSAGE= ${WRKSRC}/MESSAGE
+DOCSDIR= ${PREFIX}/share/doc/ja/${PORTNAME}
PATCHES= pastel.diff
.include <bsd.port.pre.mk>
@@ -86,9 +88,9 @@ pre-configure:
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/instgame ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/ja/xsystem35
+ @${MKDIR} ${PREFIX}/${DOCSDIR}
(cd ${WRKSRC}/doc;\
- ${INSTALL_MAN} * ${PREFIX}/share/doc/ja/xsystem35)
+ ${INSTALL_MAN} * ${PREFIX}/${DOCSDIR})
.endif
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/src/xsys35rc.sample ${EXAMPLESDIR}