aboutsummaryrefslogtreecommitdiff
path: root/emulators/yabause/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-24 22:50:00 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-24 22:50:00 +0000
commitc4bae5559667772cd374a975ab7f97f36f1eb9eb (patch)
treeaf946260564543bc8daa056add92c191a47b38d8 /emulators/yabause/Makefile
parent091e3e7c5c3fae5885e6a04b4f3ee3fa81fb33f3 (diff)
- New port: emulators/yabause
Yabause is a Sega Saturn emulator. It currently runs on GNU/Linux, FreeBSD and is being ported to Microsoft Windows and Mac OS X. It is also ported to the Sega Dreamcast as a separate project. It is written in C using the SDL and OpenGL libraries with support for cdrom and iso files. WWW: http://yabause.sourceforge.net/ Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=171346
Diffstat (limited to 'emulators/yabause/Makefile')
-rw-r--r--emulators/yabause/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
new file mode 100644
index 000000000000..2811c33b061d
--- /dev/null
+++ b/emulators/yabause/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: yabause
+# Date created: 2006-08-23
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yabause
+PORTVERSION= 0.7.0
+CATEGORIES= emulators
+MASTER_SITES= SF
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Sega Saturn system emulator
+
+LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= yes
+USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:259
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SUB_FILES= pkg-message
+PLIST_DIRS= share/yabause
+PLIST_FILES= bin/gen68k \
+ bin/yabause \
+ share/yabause/c68k_ini.inc
+MAN1= yabause.1
+
+post-install:
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>