aboutsummaryrefslogtreecommitdiff
path: root/emulators/yabause
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-24 22:50:00 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-08-24 22:50:00 +0000
commitc4bae5559667772cd374a975ab7f97f36f1eb9eb (patch)
treeaf946260564543bc8daa056add92c191a47b38d8 /emulators/yabause
parent091e3e7c5c3fae5885e6a04b4f3ee3fa81fb33f3 (diff)
downloadports-c4bae5559667772cd374a975ab7f97f36f1eb9eb.tar.gz
ports-c4bae5559667772cd374a975ab7f97f36f1eb9eb.zip
Notes
Diffstat (limited to 'emulators/yabause')
-rw-r--r--emulators/yabause/Makefile35
-rw-r--r--emulators/yabause/distinfo3
-rw-r--r--emulators/yabause/files/pkg-message.in18
-rw-r--r--emulators/yabause/pkg-descr6
4 files changed, 62 insertions, 0 deletions
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
new file mode 100644
index 000000000000..2811c33b061d
--- /dev/null
+++ b/emulators/yabause/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: yabause
+# Date created: 2006-08-23
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yabause
+PORTVERSION= 0.7.0
+CATEGORIES= emulators
+MASTER_SITES= SF
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Sega Saturn system emulator
+
+LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= yes
+USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:259
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SUB_FILES= pkg-message
+PLIST_DIRS= share/yabause
+PLIST_FILES= bin/gen68k \
+ bin/yabause \
+ share/yabause/c68k_ini.inc
+MAN1= yabause.1
+
+post-install:
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/emulators/yabause/distinfo b/emulators/yabause/distinfo
new file mode 100644
index 000000000000..c9c02f607caa
--- /dev/null
+++ b/emulators/yabause/distinfo
@@ -0,0 +1,3 @@
+MD5 (yabause-0.7.0.tar.gz) = b4c47ad433b2cbd6a0c9f8be5959ccff
+SHA256 (yabause-0.7.0.tar.gz) = bc67d5a189624f8d0f71c116f768eac7c1bca34ea447d4244b00ca7081487d2d
+SIZE (yabause-0.7.0.tar.gz) = 433706
diff --git a/emulators/yabause/files/pkg-message.in b/emulators/yabause/files/pkg-message.in
new file mode 100644
index 000000000000..37328378eb5a
--- /dev/null
+++ b/emulators/yabause/files/pkg-message.in
@@ -0,0 +1,18 @@
+###############################################################################
+
+1) You need to manually download Sega Saturn bios. It's available at:
+
+ - http://www.theoldcomputer.com/Libarary's/Emulation/BIOS_Roms/saturn.zip
+
+ Please keep in mind that the SEGA SATURN BIOS is copyrighted software.
+
+2) Run yabause
+
+ # yabause
+
+3) Go to Yabause/Preferences and configure it.(bios/cdrom/iso, video/audio,
+ memory, keyboard)
+4) Press run
+5) Enjoy it :)
+
+###############################################################################
diff --git a/emulators/yabause/pkg-descr b/emulators/yabause/pkg-descr
new file mode 100644
index 000000000000..2345d935cba1
--- /dev/null
+++ b/emulators/yabause/pkg-descr
@@ -0,0 +1,6 @@
+Yabause is a Sega Saturn emulator. It currently runs on GNU/Linux, FreeBSD and
+is being ported to Microsoft Windows and Mac OS X. It is also ported to the
+Sega Dreamcast as a separate project. It is written in C using the SDL and
+OpenGL libraries with support for cdrom and iso files.
+
+WWW: http://yabause.sourceforge.net/