aboutsummaryrefslogtreecommitdiff
path: root/emulators/yuzu/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-12-31 19:52:03 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-12-31 20:17:02 +0000
commit507fbd9eb88bd68a16853dd284faa92f7d46d311 (patch)
tree4125a5394f27dfa5cba2832713e26e3c728484cd /emulators/yuzu/Makefile
parent4f5ce01d2682ec073459cd978481323b1d3c8994 (diff)
downloadports-507fbd9eb88bd68a16853dd284faa92f7d46d311.tar.gz
ports-507fbd9eb88bd68a16853dd284faa92f7d46d311.zip
emulators/yuzu-qt5: fix Compatibility == Not Tested
yuzu embeds game compatibility list during build. It cannot be updated on demand unlike rpcs3. So, cache the list in local-distfiles. (cherry picked from commit 8042b641840f40072866f92328877baa65836b39)
Diffstat (limited to 'emulators/yuzu/Makefile')
-rw-r--r--emulators/yuzu/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 6a6b1586e8a0..60d2f8c45ad6 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -2,6 +2,10 @@ PORTNAME= yuzu
PORTVERSION= s20211228
PORTREVISION?= 0
CATEGORIES= emulators
+MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb \
+ LOCAL/jbeich:gamedb
+DISTFILES= ${PORTNAME}/compatibility_list.json:gamedb
+EXTRACT_ONLY= ${DISTFILES:N*\:gamedb:C/\:.*//}
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= 6904f055db88.patch:-p1 # https://github.com/yuzu-emu/yuzu/pull/6598 mainline-merge
@@ -107,6 +111,10 @@ post-patch:
-e 's/@GIT_DESC@/${GH_TAGNAME}/' \
${WRKSRC}/src/common/scm_rev.cpp.in
+post-configure:
+ @${CP} ${DISTFILES:M*\:gamedb:C/\:.*//:S,^,${_DISTDIR},} \
+ ${BUILD_WRKSRC}/dist/compatibility_list/
+
post-patch-VAAPI-off:
@${REINPLACE_CMD} -i .nova '/pkg_check.*libva/d' \
${WRKSRC}/CMakeLists.txt