aboutsummaryrefslogtreecommitdiff
path: root/emulators/zsnes
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-24 22:42:44 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-24 22:42:44 +0000
commit4d89db6ec3fce130356c46bbff1b7a8cdde6a4bc (patch)
treea4b6698f77b0cfbe576461eb65d2865cf598abee /emulators/zsnes
parentde9584ba62a9845e607879de6da1c0667bc410fe (diff)
downloadports-4d89db6ec3fce130356c46bbff1b7a8cdde6a4bc.tar.gz
ports-4d89db6ec3fce130356c46bbff1b7a8cdde6a4bc.zip
Notes
Diffstat (limited to 'emulators/zsnes')
-rw-r--r--emulators/zsnes/Makefile5
-rw-r--r--emulators/zsnes/files/patch-aa20
2 files changed, 24 insertions, 1 deletions
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 7143491afa4c..203467ac51d4 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zsnes
PORTVERSION= 1.36
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -36,4 +36,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
GNU_CONFIGURE= yes
ALL_TARGET= ALL
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/emulators/zsnes/files/patch-aa b/emulators/zsnes/files/patch-aa
new file mode 100644
index 000000000000..a8547a18074d
--- /dev/null
+++ b/emulators/zsnes/files/patch-aa
@@ -0,0 +1,20 @@
+--- linux/sdllink.c.orig Mon May 31 01:15:18 2004
++++ linux/sdllink.c Mon May 31 01:16:17 2004
+@@ -493,7 +493,7 @@
+ int InitSound(void)
+ {
+ SDL_AudioSpec wanted;
+- const int samptab[7] = { 1, 1, 2, 4, 2, 4, 4 };
++ const int samptab[7] = { 64, 64, 128, 256, 128, 256, 256 };
+ const int freqtab[7] = { 8000, 11025, 22050, 44100, 16000, 32000, 48000 };
+
+ SDL_CloseAudio();
+@@ -519,7 +519,7 @@
+ wanted.channels = 1;
+ }
+
+- wanted.samples = samptab[SoundQuality] * 128 * wanted.channels;
++ wanted.samples = samptab[SoundQuality] * 8 * wanted.channels;
+ wanted.format = AUDIO_S16LSB;
+ wanted.userdata = NULL;
+ wanted.callback = UpdateSound;