aboutsummaryrefslogtreecommitdiff
path: root/emulators/zsnes
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /emulators/zsnes
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'emulators/zsnes')
-rw-r--r--emulators/zsnes/Makefile8
-rw-r--r--emulators/zsnes/files/patch-zpng.c10
2 files changed, 14 insertions, 4 deletions
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index 1a54a31da7d9..9169b432b3c5 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zsnes
PORTVERSION= 1.51
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ZSNES%20v${PORTVERSION}
@@ -18,7 +18,7 @@ COMMENT= Intel x86 only Super Nintendo Entertainment System (SNES) Emulator
# This must be >= 0.98!
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= non-portable, for a portable emulator see emulators/snes9x
@@ -40,8 +40,8 @@ CONFIGURE_ARGS+= --disable-cpucheck
MAN1= zsnes.1
PLIST_FILES= bin/zsnes
-CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/emulators/zsnes/files/patch-zpng.c b/emulators/zsnes/files/patch-zpng.c
new file mode 100644
index 000000000000..11fe1536d4f4
--- /dev/null
+++ b/emulators/zsnes/files/patch-zpng.c
@@ -0,0 +1,10 @@
+--- zip/zpng.c.orig 2007-01-16 00:06:29.000000000 +0100
++++ zip/zpng.c 2012-05-06 16:01:13.000000000 +0200
+@@ -21,6 +21,7 @@
+
+ #ifndef NO_PNG
+ #include <png.h>
++#include <pngpriv.h>
+ #endif
+
+ #ifdef __UNIXSDL__