aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-16 00:00:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-16 00:00:46 +0000
commit1ecb9941d938e069e89c7b1c6970c4064bd43533 (patch)
tree90682aaf04f0818481746a0686d2a58bf786e3ff /emulators
parent725022468b543c54478ceafddbc32b1653b2c10e (diff)
downloadports-1ecb9941d938e069e89c7b1c6970c4064bd43533.tar.gz
ports-1ecb9941d938e069e89c7b1c6970c4064bd43533.zip
emulators/wine-devel: expose Vulkan support
VULKAN is for Vulkan-native while VKD3D is for Direct3D 12 games PR: 231248
Notes
Notes: svn path=/head/; revision=482194
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 9d2824981db4..b455c09eccb9 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -55,12 +55,14 @@ SUB_FILES= pkg-message
PORTDATA= l_intl.nls wine.inf
-OPTIONS_DEFINE= CUPS DOCS DOSBOX GNUTLS HAL LDAP LIBXSLT MPG123 OPENAL STAGING V4L VKD3D WINEMAKER X11 GECKO MONO
+OPTIONS_DEFINE= CUPS DOCS DOSBOX GNUTLS HAL LDAP LIBXSLT MPG123 OPENAL STAGING V4L VKD3D VULKAN WINEMAKER X11 GECKO MONO
OPTIONS_DEFAULT=GNUTLS X11
OPTIONS_SUB= yes
DOSBOX_DESC= Use DOSBox to run MS-DOS programs
LIBXSLT_DESC= Use libxslt (only used by msxml3.dll)
+VKD3D_DESC= Direct3D 12 support via Vulkan
+VULKAN_DESC= Vulkan API support
WINEMAKER_DESC= Fully support winemaker (requires Perl)
GECKO_DESC= Bundle Gecko MSI package for Wine
MONO_DESC= Bundle Mono MSI package for Wine
@@ -96,7 +98,12 @@ V4L_CONFIGURE_WITH= v4l
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
V4L_LIB_DEPENDS= libv4l1.so:multimedia/libv4l
-VKD3D_IGNORE= The VKD3D option is not supported (yet)
+VKD3D_CONFIGURE_WITH= vkd3d
+VKD3D_USES= pkgconfig
+VKD3D_LIB_DEPENDS= libvkd3d.so:graphics/vkd3d
+
+VULKAN_CONFIGURE_WITH= vulkan
+VULKAN_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
WINEMAKER_RUN_DEPENDS= p5-XML-LibXML>0:textproc/p5-XML-LibXML