aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 14:36:07 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 14:36:07 +0000
commit42a5e97306b40dc86af475f0c18aa9d0d0ba6020 (patch)
tree7707b5559bf6bb4992c2f8b31ce0fc28f4428d60 /emulators
parent3e505e35c24099ffcbba43a280ab13105bb3c5d1 (diff)
downloadports-42a5e97306b40dc86af475f0c18aa9d0d0ba6020.tar.gz
ports-42a5e97306b40dc86af475f0c18aa9d0d0ba6020.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mastergear/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/emulators/mastergear/Makefile b/emulators/mastergear/Makefile
index 5084c41b36da..ab98c597950c 100644
--- a/emulators/mastergear/Makefile
+++ b/emulators/mastergear/Makefile
@@ -20,15 +20,14 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
STRIP=
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mg ${PREFIX}/bin
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/CART.ROM ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/SF7000.ROM ${DATADIR}
-.if(!defined(NOPORTDOCS))
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/MG.html ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/mg ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/CART.ROM ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/SF7000.ROM ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/MG.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>