aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-10-01 17:18:19 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-10-01 17:18:19 +0000
commit6ec74a36cd454ba7d532da2a16b1b8e1f80c24ea (patch)
treef66fcd1067c1120a2f749bcf3cb0e92faefe3e8b /emulators
parentd801294043335f93a4549180a6200db3a5e0cb5e (diff)
downloadports-6ec74a36cd454ba7d532da2a16b1b8e1f80c24ea.tar.gz
ports-6ec74a36cd454ba7d532da2a16b1b8e1f80c24ea.zip
Require a modern compiler to fix build on powerpc64
PR: 231850
Notes
Notes: svn path=/head/; revision=481042
Diffstat (limited to 'emulators')
-rw-r--r--emulators/unicorn/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/emulators/unicorn/Makefile b/emulators/unicorn/Makefile
index aa566f53bb17..423ed18b9c2f 100644
--- a/emulators/unicorn/Makefile
+++ b/emulators/unicorn/Makefile
@@ -16,12 +16,11 @@ BROKEN_armv6= fails to compile: 'tcg-target.h' file not found
BROKEN_armv7= fails to compile: 'tcg-target.h' file not found
BROKEN_mips= fails to compile: 'ICACHE' undeclared (first use in this function)
BROKEN_mips64= fails to compile: 'ICACHE' undeclared (first use in this function)
-BROKEN_powerpc64= fails to compile: cc1: unrecognized command line option "-Wno-logical-op-parentheses"
USE_GITHUB= yes
GH_ACCOUNT= unicorn-engine
-USES= gmake python:2.7,build
+USES= compiler:c11 gmake python:2.7,build
USE_LDCONFIG= yes
MAKE_ENV= INSTALL_LIB="${INSTALL_LIB}" \
UNICORN_QEMU_FLAGS=--python=${PYTHON_CMD} \