aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
commitf2fc2d60ae226a1b8d5411fb4aab91ea92be6f91 (patch)
treee9a77f53d4fe679665594e718ad34b49668507cc /emulators
parent063f8ca62467e4709e58c8bb6b67c85970fe28a1 (diff)
downloadports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.tar.gz
ports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/atari800/Makefile2
-rw-r--r--emulators/bochs/Makefile2
-rw-r--r--emulators/generator/Makefile2
-rw-r--r--emulators/hatari/Makefile2
-rw-r--r--emulators/kmamerun/Makefile2
-rw-r--r--emulators/linux_base-suse-9.1/Makefile8
-rw-r--r--emulators/pearpc/Makefile2
-rw-r--r--emulators/snes9x/Makefile2
-rw-r--r--emulators/twin/Makefile2
-rw-r--r--emulators/xbraitenberg/Makefile2
-rw-r--r--emulators/zsnes/Makefile2
11 files changed, 14 insertions, 14 deletions
diff --git a/emulators/atari800/Makefile b/emulators/atari800/Makefile
index 6a47a2e4c637..a6c5ebc4433f 100644
--- a/emulators/atari800/Makefile
+++ b/emulators/atari800/Makefile
@@ -26,7 +26,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= atari800.1
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index c76123efe061..33218a950af2 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -24,7 +24,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-split-hd \
--enable-all-optimizations \
--with-x11 \
diff --git a/emulators/generator/Makefile b/emulators/generator/Makefile
index 4476c4f23f3a..1265f8023088 100644
--- a/emulators/generator/Makefile
+++ b/emulators/generator/Makefile
@@ -22,7 +22,7 @@ USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gtk
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index cfa31d4ec237..7acab72474a5 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An Atari ST emulator
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_SDL= yes
diff --git a/emulators/kmamerun/Makefile b/emulators/kmamerun/Makefile
index 1c6084e286c1..36b34b50521f 100644
--- a/emulators/kmamerun/Makefile
+++ b/emulators/kmamerun/Makefile
@@ -19,6 +19,6 @@ RUN_DEPENDS= xmame:${PORTSDIR}/emulators/xmame
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
-CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+=--build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/emulators/linux_base-suse-9.1/Makefile b/emulators/linux_base-suse-9.1/Makefile
index a6ae7f8a1742..386141aec64a 100644
--- a/emulators/linux_base-suse-9.1/Makefile
+++ b/emulators/linux_base-suse-9.1/Makefile
@@ -39,6 +39,7 @@ DISTFILES= suse-release-9.1-0.i586.rpm \
libgcc-3.3.3-41.i586.rpm \
termcap-2.0.8-876.i586.rpm \
freetype2-2.1.7-53.i586.rpm
+EXTRACT_ONLY=
MAINTAINER= trevor@FreeBSD.org
COMMENT= Basic packages for Linux mode from SUSE 9.1/i386
@@ -51,7 +52,7 @@ CONFLICTS= linux_base-6* linux_base-7* linux_base-debian* \
NO_LATEST_LINK= yes
RESTRICTED= "binaries under GNU GPL without accompanying source"
ONLY_FOR_ARCHS= i386
-DIST_SUBDIR= rpm/${MACHINE_ARCH}/suse
+DIST_SUBDIR= rpm/${ARCH}/suse
PREFIX= ${LINUXBASE}
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
@@ -81,7 +82,7 @@ FALLBACK_ELF_MIB= kern.fallback_elf_brand
LINUX_ELF= 3
PREVIOUS_ELF!= /sbin/sysctl -n ${FALLBACK_ELF_MIB}
-do-extract:
+pre-install:
#
# Handle the loading of the linux loadable kernel module if required.
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -112,7 +113,7 @@ do-extract:
# mtab in etc, albeit an empty one. This is needed in a couple of
# cases. Most notably staroffice6.
#
- ${INSTALL} ${COPY} -m 644 ${FILESDIR}/yp.conf ${WRKSRC}/etc
+ ${INSTALL_DATA} ${FILESDIR}/yp.conf ${WRKSRC}/etc
${TOUCH} ${WRKSRC}/etc/mtab ${WRKSRC}/etc/host.conf
#
# Finish
@@ -125,7 +126,6 @@ do-extract:
done
@${LN} -sf /var/tmp ${WRKSRC}/usr/tmp
-pre-install:
${RM} -f ${PLIST}
cd ${WRKSRC} && ${FIND} -s . -type f -o -type l | \
${CUT} -c3-999 >> ${PLIST} \
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 4e85deb336f9..d893ddb03b8b 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -17,7 +17,7 @@ COMMENT= PowerPC emulator
USE_XLIB= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= ppc.1
diff --git a/emulators/snes9x/Makefile b/emulators/snes9x/Makefile
index c9ac5f7b7bdb..81be44a46e8a 100644
--- a/emulators/snes9x/Makefile
+++ b/emulators/snes9x/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
USE_X_PREFIX= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= INCLUDES="-I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDLIBS="-L${X11BASE}/lib ${PTHREAD_LIBS}" \
OPTIMISE="${CXXFLAGS}"
diff --git a/emulators/twin/Makefile b/emulators/twin/Makefile
index e8a042738ba1..112eae21dad5 100644
--- a/emulators/twin/Makefile
+++ b/emulators/twin/Makefile
@@ -25,7 +25,7 @@ USE_XLIB= yes
USE_REINPLACE= yes
USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
-.if ${MACHINE_ARCH} == "alpha"
+.if ${ARCH} == "alpha"
CONFIGURE_ARGS+=--disable-intp
.endif
USE_GMAKE= yes
diff --git a/emulators/xbraitenberg/Makefile b/emulators/xbraitenberg/Makefile
index 06dd79ca6176..6c5942238441 100644
--- a/emulators/xbraitenberg/Makefile
+++ b/emulators/xbraitenberg/Makefile
@@ -15,7 +15,7 @@ COMMENT= A Braitenberg vehicle simulator with pseudo-physics
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index e5355f4fb097..6ff04da6cf49 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -31,7 +31,7 @@ USE_GL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yyes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= ALL