aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:58:19 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:58:19 +0000
commit6a2753b940fb71400b6b4db0d2304804dabfb1dc (patch)
tree0055682f29cef5cc8cf94d540890c2adb1c2ac04 /emulators
parent66bef42e6b828d3fe36ce421f466fcc6ac224004 (diff)
downloadports-6a2753b940fb71400b6b4db0d2304804dabfb1dc.tar.gz
ports-6a2753b940fb71400b6b4db0d2304804dabfb1dc.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64-glide/Makefile65
-rw-r--r--emulators/mupen64-glide/distinfo2
-rw-r--r--emulators/mupen64-glide/files/extra-patch-main.cpp41
-rw-r--r--emulators/mupen64-glide/files/extra-patch-main.h13
-rw-r--r--emulators/mupen64-glide/files/patch-Makefile19
-rw-r--r--emulators/mupen64-glide/files/patch-glidesys.h11
-rw-r--r--emulators/mupen64-glide/pkg-descr15
-rw-r--r--emulators/mupen64-glide/pkg-message9
9 files changed, 176 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index bce56685e639..8f52617e6d05 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -62,6 +62,7 @@
SUBDIR += mtools
SUBDIR += mupen64-base
SUBDIR += mupen64-dummyaudio
+ SUBDIR += mupen64-glide
SUBDIR += osf1_base
SUBDIR += p-interp
SUBDIR += pcemu
diff --git a/emulators/mupen64-glide/Makefile b/emulators/mupen64-glide/Makefile
new file mode 100644
index 000000000000..bfcef7b12339
--- /dev/null
+++ b/emulators/mupen64-glide/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: mupen64-glide
+# Date created: 11.Aug 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64
+PORTVERSION= 0.7
+CATEGORIES+= emulators
+MASTER_SITES= http://mupen64.emulation64.com/files/0.4/
+PKGNAMESUFFIX= -glide
+DISTNAME= glide64_0_7_ME
+
+MAINTAINER?= tlp@LiquidX.org
+COMMENT= Glide64 graphics plugin for Mupen64
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+USE_GNOME= gtk12
+USE_XLIB= yes
+USE_GCC= 3.4
+ONLY_FOR_ARCHS= i386
+
+PLUGIN_NAME= Glide64
+PLIST_FILES= share/mupen64/plugins/${PLUGIN_NAME}.so
+PLIST_FILES+= share/mupen64/plugins/${PLUGIN_NAME}.ini
+PLIST_DIRS= share/mupen64/plugins
+PLIST_DIRS+= share/mupen64
+
+FIXME2= wrapper/main.cpp
+
+do-configure:
+.for i in ${FIXME2}
+ ${REINPLACE_CMD} -e 's|SDL/SDL.h|SDL.h|' ${WRKSRC}/${i}
+.endfor
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/mupen64/plugins
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PLUGIN_NAME}.so \
+ ${PREFIX}/share/mupen64/plugins/
+ ${INSTALL_DATA} ${WRKSRC}/${PLUGIN_NAME}.ini \
+ ${PREFIX}/share/mupen64/plugins/
+
+.include <bsd.port.pre.mk>
+
+.if defined(X_WINDOW_SYSTEM) && ${X_WINDOW_SYSTEM:L} == xorg
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-main.cpp \
+ ${FILESDIR}/extra-patch-main.h
+.endif
+
+CFLAGS+= -Iwrapper/ `${SDL_CONFIG} --cflags`
+CFLAGS+= -DUSE_GTK `${GTK_CONFIG} --cflags` -fPIC
+CFLAGS+= -O3 -fomit-frame-pointer -funroll-loops -ffast-math -Wall -pipe
+CFLAGS+= -DX86 -mcpu=athlon
+LDFLAGS+= -lGL -lGLU -L${X11BASE}/lib `${SDL_CONFIG} --libs` -lc
+
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LD="${CXX}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mupen64-glide/distinfo b/emulators/mupen64-glide/distinfo
new file mode 100644
index 000000000000..4f5e3fd88de9
--- /dev/null
+++ b/emulators/mupen64-glide/distinfo
@@ -0,0 +1,2 @@
+MD5 (glide64_0_7_ME.tar.bz2) = 3078c5c3f960728f99af825ab0af69e0
+SIZE (glide64_0_7_ME.tar.bz2) = 231051
diff --git a/emulators/mupen64-glide/files/extra-patch-main.cpp b/emulators/mupen64-glide/files/extra-patch-main.cpp
new file mode 100644
index 000000000000..6cb9dc93c9b5
--- /dev/null
+++ b/emulators/mupen64-glide/files/extra-patch-main.cpp
@@ -0,0 +1,41 @@
+--- wrapper/main.cpp.orig Fri Jul 2 21:57:48 2004
++++ wrapper/main.cpp Fri Aug 13 21:21:15 2004
+@@ -3,7 +3,7 @@
+ #include <stdarg.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include <SDL/SDL.h>
++#include <SDL.h>
+ #endif // _WIN32
+ #include "glide.h"
+ #include <stdlib.h>
+@@ -20,9 +20,13 @@
+ #endif // _WIN32
+
+
++#ifndef __FreeBSD__
+ PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
++#endif
+ PFNGLBLENDFUNCSEPARATEEXTPROC glBlendFuncSeparateEXT;
++#ifndef __FreeBSD__
+ PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
++#endif
+ PFNGLFOGCOORDFPROC glFogCoordfEXT;
+ #ifdef _WIN32
+ PFNWGLGETEXTENSIONSSTRINGARBPROC wglGetExtensionsStringARB;
+@@ -501,6 +505,7 @@
+ if (isExtensionSupported("GL_ARB_texture_mirrored_repeat") == FALSE)
+ display_warning((unsigned char*)"Your video card doesn't support GL_ARB_texture_mirrored_repeat extension");
+
++#ifndef __FreeBSD__
+ #ifdef _WIN32
+ glActiveTextureARB = (PFNGLACTIVETEXTUREARBPROC)wglGetProcAddress("glActiveTextureARB");
+ glMultiTexCoord2fARB = (PFNGLMULTITEXCOORD2FARBPROC)wglGetProcAddress("glMultiTexCoord2fARB");
+@@ -508,6 +513,7 @@
+ glActiveTextureARB = (PFNGLACTIVETEXTUREARBPROC)SDL_GL_GetProcAddress("glActiveTextureARB");
+ glMultiTexCoord2fARB = (PFNGLMULTITEXCOORD2FARBPROC)SDL_GL_GetProcAddress("glMultiTexCoord2fARB");
+ #endif // _WIN32
++#endif
+ glGetIntegerv(GL_MAX_TEXTURE_UNITS_ARB, &nbTextureUnits);
+ if (nbTextureUnits == 1) display_warning((unsigned char*)"You need a video card that has at least 2 texture units");
+
diff --git a/emulators/mupen64-glide/files/extra-patch-main.h b/emulators/mupen64-glide/files/extra-patch-main.h
new file mode 100644
index 000000000000..aefbaa4f1fd0
--- /dev/null
+++ b/emulators/mupen64-glide/files/extra-patch-main.h
@@ -0,0 +1,13 @@
+--- wrapper/main.h.orig Sun Jun 20 21:08:48 2004
++++ wrapper/main.h Fri Aug 13 21:17:22 2004
+@@ -16,8 +16,10 @@
+ void updateCombinera(int i);
+
+ //#ifdef _WIN32
++#ifndef __FreeBSD__
+ extern PFNGLACTIVETEXTUREARBPROC glActiveTextureARB;
+ extern PFNGLMULTITEXCOORD2FARBPROC glMultiTexCoord2fARB;
++#endif
+ extern PFNGLBLENDFUNCSEPARATEEXTPROC glBlendFuncSeparateEXT;
+ extern PFNGLFOGCOORDFPROC glFogCoordfEXT;
+ //#endif // _WIN32
diff --git a/emulators/mupen64-glide/files/patch-Makefile b/emulators/mupen64-glide/files/patch-Makefile
new file mode 100644
index 000000000000..8e1dffb0fbec
--- /dev/null
+++ b/emulators/mupen64-glide/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Sat Jul 3 23:07:06 2004
++++ Makefile Thu Aug 12 17:06:38 2004
+@@ -1,11 +1,11 @@
+-CC = gcc
++#CC = gcc
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -g -mmmx -msse
+ #CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+-CXX = g++
++#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -Iwrapper/ -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
++#CXX = g++
+ CPPFLAGS = $(CFLAGS)
+-LD = g++
+-LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
++#LD = g++
++#LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
+
+ OBJECTS = Main.o \
+ rdp.o \
diff --git a/emulators/mupen64-glide/files/patch-glidesys.h b/emulators/mupen64-glide/files/patch-glidesys.h
new file mode 100644
index 000000000000..27fe0cdb5d31
--- /dev/null
+++ b/emulators/mupen64-glide/files/patch-glidesys.h
@@ -0,0 +1,11 @@
+--- wrapper/glidesys.h.orig Sun Jun 13 23:58:12 2004
++++ wrapper/glidesys.h Thu Aug 12 17:14:11 2004
+@@ -96,7 +96,7 @@
+ #endif
+
+ /* Check for OS */
+-#if defined(__IRIX__) || defined(__sparc__) || defined(__linux__)
++#if defined(__IRIX__) || defined(__sparc__) || defined(__linux__) || defined(__FreeBSD__)
+ # define GLIDE_OS GLIDE_OS_UNIX
+ #elif defined(__DOS__)
+ # define GLIDE_OS GLIDE_OS_DOS32
diff --git a/emulators/mupen64-glide/pkg-descr b/emulators/mupen64-glide/pkg-descr
new file mode 100644
index 000000000000..7190eb7315dd
--- /dev/null
+++ b/emulators/mupen64-glide/pkg-descr
@@ -0,0 +1,15 @@
+Glide64 graphics plugin for Mupen64
+-
+Mupen64 is a highly portable Nintendo 64 emulator. It has been developed
+on/for Linux originally but has already been ported successfully to other
+operating systems. The program can easily be ported to all operating systems
+supported by the SDL library.
+
+In its current state, the emulator is highly compatible and uses a plugin
+system. With the correct plugins ("correct" can be computer dependent), it
+can achieve nearly perfect graphics and sound in many games.
+
+WWW: http://mupen64.emulation64.com/
+
+- Travis Poppe
+tlp@liquidx.org
diff --git a/emulators/mupen64-glide/pkg-message b/emulators/mupen64-glide/pkg-message
new file mode 100644
index 000000000000..d53470396a22
--- /dev/null
+++ b/emulators/mupen64-glide/pkg-message
@@ -0,0 +1,9 @@
+-------------------------------------------------------------------------------
+If you have installed/upgraded any new plugins or are upgrading from a previous
+version of Mupen64, please note that in order for these changes to take effect,
+you -must- backup and then remove ~/.mupen64 first. After you have removed the
+directory, run 'mupen64' to re-create it. Then, manually copy back your save
+files/other data you need from the backup if necessary.
+
+Enjoy!
+-------------------------------------------------------------------------------