aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2014-01-02 10:23:41 +0000
committerDavid Naylor <dbn@FreeBSD.org>2014-01-02 10:23:41 +0000
commit1878a27907bbca7c091000411fac170a9861f5eb (patch)
tree002459e9bca0f9025c9ccdb7c193313e78142c98 /emulators
parentb9f174abec1eee3710c93d50fc6c5bf035ff549a (diff)
downloadports-1878a27907bbca7c091000411fac170a9861f5eb.tar.gz
ports-1878a27907bbca7c091000411fac170a9861f5eb.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile100
-rw-r--r--emulators/wine-devel/distinfo4
-rw-r--r--emulators/wine-devel/pkg-plist29
3 files changed, 60 insertions, 73 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 8a8171f8576b..43f2c617dab0 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wine
-DISTVERSION= 1.7.8
+DISTVERSION= 1.7.9
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -43,7 +43,7 @@ USE_BZIP2= yes
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS_DEFINE= CUPS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO X11
+OPTIONS_DEFINE= CUPS DOCS DOSBOX GNUTLS HAL LDAP LIBXSLT OPENAL WINEMAKER GECKO MONO X11
OPTIONS_DEFAULT=X11
OPTIONS_SUB= yes
@@ -54,88 +54,46 @@ GECKO_DESC= Bundle Gecko MSI package for Wine
MONO_DESC= Bundle Mono MSI package for Wine
# USES needs to be before bsd.port.pre.mk
-OPENAL_USES= openal
+CUPS_CONFIGURE_WITH= cups
+CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
-PORTDATA= l_intl.nls wine.inf
+DOSBOX_RUN_DEPENDS= dosbox:${PORTSDIR}/emulators/dosbox
-.include <bsd.port.pre.mk>
+GECKO_RUN_DEPENDS= ${DATADIR}/gecko/wine_gecko-2.24-x86.msi:${PORTSDIR}/emulators/wine-gecko-devel
-.if ${PORT_OPTIONS:MCUPS}
-CONFIGURE_ARGS+= --with-cups
-LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
-.else
-CONFIGURE_ARGS+= --without-cups
-.endif
+GNUTLS_CONFIGURE_WITH= gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
-.if ${PORT_OPTIONS:MDOSBOX}
-RUN_DEPENDS+= dosbox:${PORTSDIR}/emulators/dosbox
-.endif
+HAL_CONFIGURE_WITH= hal
+HAL_LIB_DEPENDS= libhal.so:${PORTSDIR}/sysutils/hal
-.if ${PORT_OPTIONS:MGNUTLS}
-CONFIGURE_ARGS+= --with-gnutls
-LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
-.else
-CONFIGURE_ARGS+= --without-gnutls
-.endif
+LDAP_CONFIGURE_WITH= ldap
+LDAP_USE= OPENLDAP=yes
-.if ${PORT_OPTIONS:MHAL}
-CONFIGURE_ARGS+= --with-hal
-LIB_DEPENDS+= libhal.so:${PORTSDIR}/sysutils/hal
-.else
-CONFIGURE_ARGS+= --without-hal
-.endif
+LIBXSLT_CONFIGURE_WITH= xslt
+LIBXSLT_LIB_DEPENDS= libxslt.so:${PORTSDIR}/textproc/libxslt
-.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+= --with-ldap
-USE_OPENLDAP= yes
-.else
-CONFIGURE_ARGS+= --without-ldap
-.endif
+MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
-.if ${PORT_OPTIONS:MLIBXSLT}
-CONFIGURE_ARGS+= --with-xslt
-LIB_DEPENDS+= libxslt.so:${PORTSDIR}/textproc/libxslt
-.else
-CONFIGURE_ARGS+= --without-xslt
-.endif
+OPENAL_CONFIGURE_WITH= openal
+OPENAL_USES= openal
-.if ${PORT_OPTIONS:MOPENAL}
-CONFIGURE_ARGS+= --with-openal
-.else
-CONFIGURE_ARGS+= --without-openal
-.endif
+WINEMAKER_RUN_DEPENDS= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
-.if ${PORT_OPTIONS:MWINEMAKER}
-RUN_DEPENDS+= p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
-.endif
+X11_CONFIGURE_WITH= x fontconfig glu opengl xinput2 xrandr freetype
+X11_USE= GL=glu XORG=xcursor,xi,xpm,xrandr,xrender
+X11_LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libpng15.so:${PORTSDIR}/graphics/png
-.if ${PORT_OPTIONS:MGECKO}
-RUN_DEPENDS+= ${DATADIR}/gecko/wine_gecko-2.24-x86.msi:${PORTSDIR}/emulators/wine-gecko-devel
-.endif
+PORTDATA= l_intl.nls wine.inf
-.if ${PORT_OPTIONS:MMONO}
-RUN_DEPENDS+= ${DATADIR}/mono/wine-mono-0.0.8.msi:${PORTSDIR}/emulators/wine-mono
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
-USE_GL= glu
-USE_XORG= xcursor xi xpm xrandr xrender
-LIB_DEPENDS+= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
- liblcms2.so:${PORTSDIR}/graphics/lcms2 \
- libpng15.so:${PORTSDIR}/graphics/png
-CONFIGURE_ARGS+=--with-fontconfig --with-glu --with-opengl \
- --with-xinput2 --with-xrandr --with-freetype
PORTDATA+= fonts/
-.else
-CONFIGURE_ARGS+=--without-x --without-fontconfig --without-glu \
- --without-opengl --without-xinput2 --without-xrandr \
- --without-freetype
-.endif
-
-.if ${OSVERSION} < 800000
-IGNORE= lacks required sound support on FreeBSD before 8.0
.endif
pre-build:
@@ -145,7 +103,7 @@ post-install:
@${MV} -f ${STAGEDIR}${WINELIBDIR}/libwine.so.1.0 \
${STAGEDIR}${WINELIBDIR}/libwine.so.1
@${LN} -sf libwine.so.1 ${STAGEDIR}/${WINELIBDIR}/libwine.so
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
-@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in README ANNOUNCE AUTHORS
@${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
@@ -156,4 +114,4 @@ post-install:
@${ECHO}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 37a4bfafd512..d9cef24ab949 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wine-1.7.8.tar.bz2) = 30e17f5f863a09416f3d229666566b318dbb40f683d4ca6630012c60bb511804
-SIZE (wine-1.7.8.tar.bz2) = 21463503
+SHA256 (wine-1.7.9.tar.bz2) = 79f99ecc24696915439c474c4953bb77652ab53f16b41daa4da270fe43279c5a
+SIZE (wine-1.7.9.tar.bz2) = 21323337
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 6d4ce173cbc5..4986a15099f5 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -111,11 +111,17 @@ include/wine/windows/axextend.idl
include/wine/windows/basetsd.h
include/wine/windows/basetyps.h
include/wine/windows/bcrypt.h
+include/wine/windows/bdaiface.h
+include/wine/windows/bdaiface.idl
+include/wine/windows/bdaiface_enums.h
+include/wine/windows/bdatypes.h
include/wine/windows/binres.idl
include/wine/windows/bits.h
include/wine/windows/bits.idl
include/wine/windows/bits1_5.h
include/wine/windows/bits1_5.idl
+include/wine/windows/bits3_0.h
+include/wine/windows/bits3_0.idl
include/wine/windows/bitsmsg.h
include/wine/windows/cderr.h
include/wine/windows/cfgmgr32.h
@@ -602,6 +608,8 @@ include/wine/windows/structuredquerycondition.idl
include/wine/windows/svrapi.h
include/wine/windows/t2embapi.h
include/wine/windows/tapi.h
+include/wine/windows/taskschd.h
+include/wine/windows/taskschd.idl
include/wine/windows/tchar.h
include/wine/windows/tcpmib.h
include/wine/windows/textserv.h
@@ -781,11 +789,13 @@ lib/wine/api-ms-win-downlevel-version-l1-1-0.dll.so
lib/wine/api-ms-win-security-base-l1-1-0.dll.so
lib/wine/apphelp.dll.so
lib/wine/appwiz.cpl.so
+lib/wine/arp.exe.so
lib/wine/aspnet_regiis.exe.so
lib/wine/atl.dll.so
lib/wine/atl100.dll.so
lib/wine/atl110.dll.so
lib/wine/atl80.dll.so
+lib/wine/atl90.dll.so
lib/wine/attrib.exe.so
lib/wine/authz.dll.so
lib/wine/avicap32.dll.so
@@ -945,11 +955,13 @@ lib/wine/fakedlls/api-ms-win-downlevel-version-l1-1-0.dll
lib/wine/fakedlls/api-ms-win-security-base-l1-1-0.dll
lib/wine/fakedlls/apphelp.dll
lib/wine/fakedlls/appwiz.cpl
+lib/wine/fakedlls/arp.exe
lib/wine/fakedlls/aspnet_regiis.exe
lib/wine/fakedlls/atl.dll
lib/wine/fakedlls/atl100.dll
lib/wine/fakedlls/atl110.dll
lib/wine/fakedlls/atl80.dll
+lib/wine/fakedlls/atl90.dll
lib/wine/fakedlls/attrib.exe
lib/wine/fakedlls/authz.dll
lib/wine/fakedlls/avicap32.dll
@@ -1584,8 +1596,12 @@ lib/wine/libmsdmo.def
lib/wine/libmshtml.def
lib/wine/libmsi.def
lib/wine/libmsimg32.def
+lib/wine/libmsvcr100.def
+lib/wine/libmsvcr110.def
lib/wine/libmsvcr70.def
lib/wine/libmsvcr71.def
+lib/wine/libmsvcr80.def
+lib/wine/libmsvcr90.def
lib/wine/libmsvcrt.def
lib/wine/libmsvcrt20.def
lib/wine/libmsvcrt40.def
@@ -1995,6 +2011,12 @@ lib/wine/xmllite.dll.so
lib/wine/xolehlp.dll.so
lib/wine/xpsprint.dll.so
lib/wine/xpssvcs.dll.so
+man/de.UTF-8/man1/wine.1.gz
+man/de.UTF-8/man1/winemaker.1.gz
+man/de.UTF-8/man1/wineserver.1.gz
+man/fr.UTF-8/man1/wine.1.gz
+man/fr.UTF-8/man1/winemaker.1.gz
+man/fr.UTF-8/man1/wineserver.1.gz
man/man1/msiexec.1.gz
man/man1/notepad.1.gz
man/man1/regedit.1.gz
@@ -2017,6 +2039,7 @@ man/man1/winepath.1.gz
man/man1/wineserver.1.gz
man/man1/wmc.1.gz
man/man1/wrc.1.gz
+man/pl.UTF-8/man1/wine.1.gz
share/applications/wine.desktop
%%PORTDOCS%%%%DOCSDIR%%/ANNOUNCE
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
@@ -2024,6 +2047,12 @@ share/applications/wine.desktop
%%PORTDOCS%%%%DOCSDIR%%/README.winedbg
%%PORTDOCS%%%%DOCSDIR%%/README.winedump
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry man/pl.UTF-8/man1
+@dirrmtry man/pl.UTF-8
+@dirrmtry man/fr.UTF-8/man1
+@dirrmtry man/fr.UTF-8
+@dirrmtry man/de.UTF-8/man1
+@dirrmtry man/de.UTF-8
@dirrm lib/wine/fakedlls
@dirrm lib/wine
@dirrm include/wine/windows/ddk