aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-29 08:57:12 +0000
commit5271da855f0c5946ff1f3aa58fbe806871df2f87 (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /emulators
parent8730c99d5ea1ba861dbab3e0dbc07e16826b1a7a (diff)
downloadports-5271da855f0c5946ff1f3aa58fbe806871df2f87.tar.gz
ports-5271da855f0c5946ff1f3aa58fbe806871df2f87.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux_base-fc4/Makefile17
-rw-r--r--emulators/mupen64-base/Makefile.common6
-rw-r--r--emulators/mupen64plus-core/Makefile6
-rw-r--r--emulators/mupen64plus-core/Makefile.common2
-rw-r--r--emulators/mupen64plus-rsp-z64/Makefile2
-rw-r--r--emulators/mupen64plus-video-arachnoid/Makefile2
-rw-r--r--emulators/mupen64plus-video-glide64/Makefile2
-rw-r--r--emulators/mupen64plus-video-z64/Makefile2
-rw-r--r--emulators/x48/Makefile2
9 files changed, 14 insertions, 27 deletions
diff --git a/emulators/linux_base-fc4/Makefile b/emulators/linux_base-fc4/Makefile
index 67bfa9efdf42..b02aa5ceef60 100644
--- a/emulators/linux_base-fc4/Makefile
+++ b/emulators/linux_base-fc4/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: linux_base-fc4
-# Date created: 2006-31-05
-# Whom: bsam@ipt.ru
-# based on ports/emulators/linux_base-fc3 by netchild and myself
-#
+# Created by: bsam@ipt.ru
# $FreeBSD$
-#
PORTNAME= fc
PORTVERSION= 4
@@ -106,14 +101,10 @@ NO_WRKSUBDIR= yes
DISTINFO_FILE?= ${MASTERDIR}/distinfo.${LINUX_RPM_ARCH}
PLIST_SUB= GLIBCVER="2.3.6"
-RPM2CPIO?= ${LOCALBASE}/bin/rpm2cpio
-
-EXTRACT_DEPENDS+= ${RPM2CPIO}:${PORTSDIR}/archivers/rpm
-
EXTRACT_ONLY= ${BIN_DISTFILES}
-EXTRACT_CMD?= ${RPM2CPIO}
-EXTRACT_BEFORE_ARGS?=
-EXTRACT_AFTER_ARGS?= | ${CPIO} -id --quiet
+EXTRACT_CMD= ${TAR}
+EXTRACT_BEFORE_ARGS= -xf
+EXTRACT_AFTER_ARGS= #
.include <bsd.port.pre.mk>
diff --git a/emulators/mupen64-base/Makefile.common b/emulators/mupen64-base/Makefile.common
index 3977fca20f68..51a2773d9e83 100644
--- a/emulators/mupen64-base/Makefile.common
+++ b/emulators/mupen64-base/Makefile.common
@@ -4,7 +4,7 @@ DISTNAME= ${PORTNAME}_src-${MUPEN64VERSION}
PATCHDIR= ${.CURDIR}/files
WRKSRC?= ${WRKDIR}/${DISTNAME}
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${DISTNAME}/Makefile ${DISTNAME}/config.h \
+EXTRACT_AFTER_ARGS= ${DISTNAME}/Makefile ${DISTNAME}/config.h \
${DISTNAME}/main ${DISTNAME}/plugins
.if defined(HAVE_GTK2)
@@ -73,7 +73,7 @@ ALL_TARGET= plugins/Glide64.so
DISTINFO_FILE= ${.CURDIR}/distinfo
DISTNAME= ${PKGNAMESUFFIX:S/-//:S/$/64/}-${PORTVERSION:S/$/.SP8/}
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+EXTRACT_AFTER_ARGS= #
EXTRA_PATCHES= #
.endif
@@ -83,7 +83,7 @@ ALL_TARGET= plugins/tr64gl.so
DISTINFO_FILE= ${.CURDIR}/distinfo
DISTNAME= ${PKGNAMESUFFIX:S/-//}_ogl_gtk2-${PORTVERSION}
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+EXTRACT_AFTER_ARGS= #
EXTRA_PATCHES= #
WRKSRC= ${WRKDIR}/${PKGNAMESUFFIX:S/-//}_ogl-${PORTVERSION}
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index 7098bdb5967d..e965289f3469 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mupen64plus-core
-# Date created: 2008-05-16
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
+# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= mupen64plus
PORTVERSION?= 1.99.4
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index 3c5c2969a2cd..aca1c2a0fa4d 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -5,7 +5,7 @@ PATCHDIR= ${.CURDIR}/files
BUILD_WRKSRC?= ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC?= ${WRKDIR}/${DISTNAME}
-EXTRACT_AFTER_ARGS?= | ${TAR} -xf - "${DISTNAME}/source/${PORTNAME}-core/*" \
+EXTRACT_AFTER_ARGS?= "${DISTNAME}/source/${PORTNAME}-core/*" \
"${DISTNAME}/source/${PORTNAME}${PKGNAMESUFFIX}/*"
.if ${PKGNAMESUFFIX} == "-core"
diff --git a/emulators/mupen64plus-rsp-z64/Makefile b/emulators/mupen64plus-rsp-z64/Makefile
index 4c6950b58322..cbb1c1210e94 100644
--- a/emulators/mupen64plus-rsp-z64/Makefile
+++ b/emulators/mupen64plus-rsp-z64/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= #
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
LDFLAGS+= -L${LOCALBASE}/lib
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+EXTRACT_AFTER_ARGS= #
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
diff --git a/emulators/mupen64plus-video-arachnoid/Makefile b/emulators/mupen64plus-video-arachnoid/Makefile
index 9e7c3d860916..039d7a3306d2 100644
--- a/emulators/mupen64plus-video-arachnoid/Makefile
+++ b/emulators/mupen64plus-video-arachnoid/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= #
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
LDFLAGS+= -L${LOCALBASE}/lib
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+EXTRACT_AFTER_ARGS= #
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
diff --git a/emulators/mupen64plus-video-glide64/Makefile b/emulators/mupen64plus-video-glide64/Makefile
index ebedda1784d1..d7418f15d5b4 100644
--- a/emulators/mupen64plus-video-glide64/Makefile
+++ b/emulators/mupen64plus-video-glide64/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= #
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
LDFLAGS+= -L${LOCALBASE}/lib
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+EXTRACT_AFTER_ARGS= #
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
diff --git a/emulators/mupen64plus-video-z64/Makefile b/emulators/mupen64plus-video-z64/Makefile
index b60b0d58b5bf..e877c2549e7e 100644
--- a/emulators/mupen64plus-video-z64/Makefile
+++ b/emulators/mupen64plus-video-z64/Makefile
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= #
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
LDFLAGS+= -L${LOCALBASE}/lib
-EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+EXTRACT_AFTER_ARGS= #
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
diff --git a/emulators/x48/Makefile b/emulators/x48/Makefile
index 8a9cf9e2e475..9a7d65217576 100644
--- a/emulators/x48/Makefile
+++ b/emulators/x48/Makefile
@@ -35,7 +35,7 @@ OPTIONS_DEFINE= DOCS
post-extract: .SILENT
# Extract official HP ROM images for GX/SX
- ${CP} ${_DISTDIR}/gxrom-r.bz2 ${WRKSRC} && ${EXTRACT_CMD} \
+ ${CP} ${_DISTDIR}/gxrom-r.bz2 ${WRKSRC} && ${BZIP2_CMD} \
-d ${WRKSRC}/gxrom-r.bz2
# The latest SX ROM revision is J, but it does not work with x48, so use E
${CP} ${_DISTDIR}/sxrom-e.bz2 ${WRKSRC} && ${EXTRACT_CMD} \