aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-11-19 23:41:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-11-19 23:41:55 +0000
commit2d68f126de221d6caed2c560840eae9b231eaaf0 (patch)
treea4e626dcfcfc7a91af456eb7e15fa4056a883f49 /emulators
parent07b27888644efc66d4ed412de3c7ba9d7b2b54af (diff)
downloadports-2d68f126de221d6caed2c560840eae9b231eaaf0.tar.gz
ports-2d68f126de221d6caed2c560840eae9b231eaaf0.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/generator-cbiere/Makefile1
-rw-r--r--emulators/generator/Makefile1
-rw-r--r--emulators/gngeo/Makefile1
-rw-r--r--emulators/gxemul/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/emulators/generator-cbiere/Makefile b/emulators/generator-cbiere/Makefile
index 7ffcd89dc2c7..e2016a581e37 100644
--- a/emulators/generator-cbiere/Makefile
+++ b/emulators/generator-cbiere/Makefile
@@ -23,6 +23,7 @@ USE_BZIP2= yes
USE_SDL= sdl
USE_GMAKE= yes
USE_GNOME= gtk12
+MAKE_JOBS_UNSAFE= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
RAZE "Use RAZE z80 emulation (only for i386)" on \
diff --git a/emulators/generator/Makefile b/emulators/generator/Makefile
index d86f7608ddbc..402ff7a3ab06 100644
--- a/emulators/generator/Makefile
+++ b/emulators/generator/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS+=--with-gtk
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
+MAKE_JOBS_UNSAFE= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
RAZE "Use RAZE z80 emulation (only for i386)" on \
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index eb64448d2e4c..9bce7aa35c0e 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -22,6 +22,7 @@ USE_GL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name="" --disable-gp2x
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_JOBS_UNSAFE= yes
CPPFLAGS= ${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include
LDFLAGS= `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 9482c1eb44ef..f298389cbad4 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -18,6 +18,7 @@ OPTIONS= X11 "X11 support" on
HAS_CONFIGURE= yes
ALL_TARGET= build
+MAKE_JOBS_UNSAFE= yes
MAN1= gxemul.1
PORTDOCS= *