aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2004-01-28 22:29:36 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2004-01-28 22:29:36 +0000
commit707a95b9e5a1c6a56d95bbe1698811563a4dbdd4 (patch)
tree85127589958cdbca8627c8e227d9829414fc9054 /emulators
parentdcdb48da4235c1cb5bdeed6c78f9b2f8a9df9fec (diff)
downloadports-707a95b9e5a1c6a56d95bbe1698811563a4dbdd4.tar.gz
ports-707a95b9e5a1c6a56d95bbe1698811563a4dbdd4.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile1
-rw-r--r--emulators/wine-devel/files/patch-loader::main.c17
-rw-r--r--emulators/wine/Makefile1
-rw-r--r--emulators/wine/files/patch-loader::main.c17
4 files changed, 36 insertions, 0 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 7b6f7e62291e..a32743501f2c 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -8,6 +8,7 @@
PORTNAME= wine
PORTVERSION= 20040121
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= ALPHA/wine/development
diff --git a/emulators/wine-devel/files/patch-loader::main.c b/emulators/wine-devel/files/patch-loader::main.c
new file mode 100644
index 000000000000..b7a60402ad5b
--- /dev/null
+++ b/emulators/wine-devel/files/patch-loader::main.c
@@ -0,0 +1,17 @@
+Index: loader/main.c
+===================================================================
+RCS file: /home/wine/wine/loader/main.c,v
+retrieving revision 1.90
+retrieving revision 1.89
+diff -u -3 -p -r1.90 -r1.89
+--- loader/main.c 20 Jan 2004 00:28:01 -0000 1.90
++++ loader/main.c 22 Nov 2003 00:08:26 -0000 1.89
+@@ -29,7 +29,7 @@ int main( int argc, char *argv[] )
+ {
+ char error[1024];
+
+-#if 0
++#ifdef __i386__
+ static char pe_load[256*1024*1024] __attribute__((aligned(4096)));
+ wine_set_pe_load_area( pe_load, sizeof(pe_load) );
+ #endif
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 7b6f7e62291e..a32743501f2c 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -8,6 +8,7 @@
PORTNAME= wine
PORTVERSION= 20040121
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= ALPHA/wine/development
diff --git a/emulators/wine/files/patch-loader::main.c b/emulators/wine/files/patch-loader::main.c
new file mode 100644
index 000000000000..b7a60402ad5b
--- /dev/null
+++ b/emulators/wine/files/patch-loader::main.c
@@ -0,0 +1,17 @@
+Index: loader/main.c
+===================================================================
+RCS file: /home/wine/wine/loader/main.c,v
+retrieving revision 1.90
+retrieving revision 1.89
+diff -u -3 -p -r1.90 -r1.89
+--- loader/main.c 20 Jan 2004 00:28:01 -0000 1.90
++++ loader/main.c 22 Nov 2003 00:08:26 -0000 1.89
+@@ -29,7 +29,7 @@ int main( int argc, char *argv[] )
+ {
+ char error[1024];
+
+-#if 0
++#ifdef __i386__
+ static char pe_load[256*1024*1024] __attribute__((aligned(4096)));
+ wine_set_pe_load_area( pe_load, sizeof(pe_load) );
+ #endif