aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-01-03 19:21:55 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-01-03 19:21:55 +0000
commitc708d5b490fea3eb7b7a396d62f618c237a025cb (patch)
tree376baccb351689c4f122a065dc6a19708ee998e3 /emulators
parent465726c27515993af61ff920091d460c2572c472 (diff)
downloadports-c708d5b490fea3eb7b7a396d62f618c237a025cb.tar.gz
ports-c708d5b490fea3eb7b7a396d62f618c237a025cb.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile10
-rw-r--r--emulators/wine/Makefile10
2 files changed, 18 insertions, 2 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index ed69b092d42b..9d8fadc7f70f 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -43,7 +43,8 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
- HAL "Use HAL (Hardware Abstraction Layer)" Off
+ HAL "Use HAL (Hardware Abstraction Layer)" Off \
+ LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
.include <bsd.port.pre.mk>
@@ -61,6 +62,13 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --without-hal
.endif
+.ifdef WITH_LIBXSLT
+CONFIGURE_ARGS+= --with-xslt
+LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
+.else
+CONFIGURE_ARGS+= --without-xslt
+.endif
+
.if ${OSVERSION} < 602000
IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index ed69b092d42b..9d8fadc7f70f 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -43,7 +43,8 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= CUPS "Use CUPS (Common UNIX Printing System)" On \
- HAL "Use HAL (Hardware Abstraction Layer)" Off
+ HAL "Use HAL (Hardware Abstraction Layer)" Off \
+ LIBXSLT "Use libxslt (only used by msxml3.dll)" Off
.include <bsd.port.pre.mk>
@@ -61,6 +62,13 @@ LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
CONFIGURE_ARGS+= --without-hal
.endif
+.ifdef WITH_LIBXSLT
+CONFIGURE_ARGS+= --with-xslt
+LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
+.else
+CONFIGURE_ARGS+= --without-xslt
+.endif
+
.if ${OSVERSION} < 602000
IGNORE= fails to properly work on versions of FreeBSD before 6.2 (due to problems with threading support)
.endif